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Credits
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Generative Music Creator

Noatikl (pronounced "noh – tickle") is a very powerful generative (MIDI) music creativity application. It is the
evolution of the SSEYO Koan Generative Music System.

Noatikl generates its MIDI notes and MIDI controller events via the integrated Noatikl (MIDI) Music Engine (NME).
This MIDI data can be used to drive 3rd party external MIDI software or hardware, such as synths, FX units and
samplers, that you connect to Noatikl, or the integrated (but optional to use) Partikl Sound Engine (PSE), a
powerful, advanced and modular synth + live FX network.

Don't forget to check out the 2 Minute Videos!

Noatikl is available for both Desktop (Windows/Mac macOS) and Mobile (iOS). Those using Desktop Audio software
generally have a preferred workflow, using either a DAW with Plugins, or using and connecting a number of
Standalone apps. So that you can use Noatikl Desktop in the way you prefer, there are 2 versions - Noatikl Desktop
Standalone and the Noatikl Desktop Audio Plugins (VSTi/Aui). The Desktop versions (only) also have extensive
built-in scripting features which allow them to be used as a customisable hyperinstruments.

This guide details the various Noatikl app interface elements and what they do, as well as other kinds of application
specific things such as installation, connecting to external MIDI sources etc. When it comes to defining how the
music and sounds are generated, however, we direct you instead to the NME Guide and PSE Guide which cover all
relevant objects, parameters and settings available.

Quick overview on the NME and how it works

The NME utilises a range of generative / aleatoric / stochastic / algorithmic music techniques and parameters and
creates MIDI notes and MIDI controller events through the interaction of 4 different kinds of NME Objects: Voice
(with 6 Voice Types), Rule (Scale, Harmony, Rhythm & Next Note), Piece and File. There can be multiple instances
of the first two objects in a "piece" and there are a large number of Voice Object parameters to affect and direct the
composition.

Rather than being a traditional composer or instrumentalist, with the Noatikl app you are conductor, director,
curator or gardener. You set up the rules and settings that let it generate a composition for you, in real time, in all
its detail. Random events in combination with a powerful set of musical rules are used to create a stream of music

https://intermorphic.com/nme/3/#scripting-objects
https://intermorphic.com/nme/3/#file
https://intermorphic.com/nme/3/#piece-basics
https://intermorphic.com/nme/3/#the-rules
https://intermorphic.com/nme/3/#voice-types
https://intermorphic.com/pse/3/index.html
https://intermorphic.com/nme/3/index.html
https://intermorphic.com/nme/3/#scripting-hyperinstrument
https://intermorphic.com/nme/3/#scripting
https://intermorphic.com/pse/3/index.html
https://intermorphic.com/nme/3/
https://intermorphic.com/sseyo/koan/index.html
https://en.wikipedia.org/wiki/MIDI
https://intermorphic.com/noatikl/#downloads
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that is ever-changing and continually fresh, but which is entirely in accordance to your personal artistic choices and
musical direction. How you interpret what you hear is filtered through your own internal knowledge of music. This
combination of chance and logic is what allows the music to stay fresh, interesting and unpredictable.

Install & Launch

Noatikl Mobile

Noatikl Mobile for iOS is installed via the iTunes App Store as part of the download process.

Noatikl Desktop user - which variant should you use?

A) Noatikl Desktop Standalone

Use this where:

You have a sequencer which does not support per-channel routing of MIDI data output by a Noatikl
Plug-in variant; or
There is no Noatikl plugin variant for your sequencer (e.g. ProTools.); or
You want to create self contained noatikl pieces that use the IM synth

Versions:

Mac - available at the Mac App Store
Windows - available as a 30 day trial from the Intermorphic web store

Noatikl Desktop Standalone runs as a tool on its own, but you can also use it to generate and send MIDI
events to a MIDI output device or virtual MIDI port. You can use it in this manner with any Windows (e.g. Sonar,
Reaper, Cubase etc.) or Mac (Logic, Cubase, Pro Tools etc.) MIDI sequencer (also referred to as a DAW or
Digital Audio Workstation) or standalone software synth or sampler.

We have created tutorials and template projects to "get you started"for some of the popular sequencers.
Download the file below, extract the contents to the appropriate place on your computer, and then follow the
appropriate tutorial to see how the template project works:

Logic 8 - template project zip
Sonar 6 - template project zip
Cubase SE 3 - template project zip

B) Noatikl Desktop Audio Plug-in

Use this where:

You have a sequencer (such as Sonar, Logic or Cubase) which supports per-channel routing of MIDI
data output by a Noatikl Audio Plug-in variant; or
You can set up your sequencer to use a Noatikl Audio Plugin to control multiple synths, all from one
instance of Noatikl (depending on how your sequencer works note timing accuracy might be dependent
of the setting for the Noatikl timer resolutions). See Cubase VSTi video tutorial or Sonar VSTi video
tutorial for examples.
NEW for Noatikl 3.3.3+: You require multiple Concurrent Instances (beyond the 2 supported as
default), and/or want to use it in a Playlist mode, and/or to extend the Music End Time (the default is

https://intermorphic.com/noatikl/index.html#sonar_vsti
https://intermorphic.com/noatikl/index.html#cubase_vsti
https://intermorphic.com/images/app/noatikl/3/resources/noatikl_standalone_template_cubase_se_3.zip
https://intermorphic.com/images/app/noatikl/3/resources/noatikl_standalone_template_sonar_6.zip
https://intermorphic.com/images/app/noatikl/3/resources/noatikl_standalone_template_logic_8.zip
https://itunes.apple.com/
http://itunes.apple.com/app/id633262318
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default), and/or want to use it in a Playlist mode, and/or to extend the Music End Time (the default is
32,000 seconds) and/or you require a licence to use the Noatikl Desktop Plugin for a period of
Commercial Use. Contact Intermorphic and subject to payment of the required fee we will generate and
provide you with the relevant Noatikl Plugin Extension key.

Versions:

Windows - Free for Noatikl 3 Intermorphic Webstore customers
Mac - Free for Noatikl 3 Mac App Store customers

If you're just using Noatikl to render audio using Noatikl's built-in PSE modular synth, then there are no special
requirements for configuring a Noatikl Audio Plug-in variant to work within your DAW. Noatikl will "just work".

However, if you want to process MIDI event data from a Noatikl Audio Plug-in variant, then you are likely to
have some configuration work to do first.

Challenge number one: Noatikl emits data for more than one MIDI channel

The most fundamental challenge with the Audio Plug-in variants of Noatikl, is that Noatikl is quite unique in the
music world; in that it generates MIDI data across more than one MIDI channel. Why does this make things
difficult? Well, most MIDI Plug-ins are designed to deal with single channels of MIDI data, such as echo or
delay FX; or even to generate simple sequences that target a single MIDI channel (such as standalone bass
lines or drum riffs).

However, if you were to assign a Noatikl Audio Plug-in variant to a MIDI track in your sequencer, you would find
that you could attach that MIDI track to render through only one soft synth (such as a VSTi synth). This is not
good ... as what you really want to do is render each channel of data generated by Noatikl through a different
synth! Some sequencers are not able to split output from MIDI Plug-ins attached to a MIDI track, on a per-MIDI
channel basis, to target different synthesizers with data from different MIDI channels generated by Noatikl!

That said, many sequencers do work well with the Noatikl VSTi; Reaper, Sonar and Cubase being examples.

Challenge number two: the wide variety of plug-in formats

There is a huge range of plug-in formats, each of which behaves differently on different platforms. Noatikl is a
MIDI-based generative music engine, and therefore is designed to emit (and respond to) MIDI events.
However, each sequencer requires a slightly different variant of plug-in!

If you wish to use Noatikl as a plug-in MIDI event generator, then which plug-in variant to use, depends on
what tool you are using, and which platform you are running on (e.g. Mac macOS or Windows).

Reaper - Noatikl is deployed as a VST plug-in, as Reaper can route MIDI events generated from a VST
plug-in into other VSTi synthesizers. Further info.
Logic / Garageband (for Mac) - Logic (which uses the Audio Unit Format, but which does not support
VST plug-ins), simply doesn’t support MIDI event generation by any Audio Unit plug-in... but we have
documented a way to work-around this this. So you have two options to consider, depending on how
you like to work: either use (follow the appropriate link to view the corresponding tutorial) the Noatikl
standalone version or the Noatikl AU version.
Cakewalk Sonar - Noatikl can be deployed in Sonar (Sonar 6 and up) as the Noatikl VSTi. See the
video tutorial and further info. The output from the Noatikl Audio Plug-in this is fed-in to your favourite
synthesizer to render the MIDI events generated by Noatikl using the exact sounds you want. Note that
there can be some timing problems inherent in using the Noatikl VSTi with Sonar; see here for more
details about how to work-around these issues.
Cubase  - Noatikl can be deployed in Cubase Windows as the Noatikl VSTi. See the video tutorial and
further info. The output from this is fed-in to your favourite VSTi to render the MIDI events using the
sounds you want.

https://intermorphic.com/noatikl/index.html#cubase_vsti
https://intermorphic.com/noatikl/#faq-sonartiming
https://intermorphic.com/noatikl/index.html#sonar_vsti
https://intermorphic.com/pse/3/index.html
https://intermorphic.com/help/index.html#contactform
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Ableton Live  - Noatikl is deployed as a VST Plug-in (Windows) or Audio Unit Plugin (macOS), See the
video tutorial and further info.

Challenge number three: not all hosts are equal!

Just to add to the challenge, not all hosts handle VSTi plug-ins correctly, and they all have their own
ideosyncratic behaviours. So you'll probably need to experiment to find the Noatikl variant that works best with
your favourite host. If in doubt, the standalone Noatikl version can usually be configured to work well with your
sequencer; though the flexibility of the plug-in approach makes it well worth the effort in giving a plug-in variant
of Noatikl a try too!

Noatikl 3 Desktop Standalone and Desktop Audio Plugins

Noatikl Desktop Standalone for Mac macOS is installed via the Mac App Store as part of the download process.

Noatikl 3 Desktop Standalone / Desktop Audio Plugin for Windows are available for download here from the
Intermorphic website as 30 day trial full versions, and are installed as below. See Enter the Product Key on how to
unlock them after the trial period is up.

Installing Noatikl 3 Desktop Software Downloaded from IM Website:

Noatikl 3 for Windows [30 Day Trial Version]: Desktop Standalone & Desktop Audio Plugin (VSTi)

Tip: You cannot install a 64-bit version on a 32-bit OS.
The zip files you can download are called noatikl_win64_standalone_setup.zip  or
noatikl_win64_plugin_setup.zip

Unzipping the relevant one for your OS will extract the file e.g.
noatikl_win64_standalone_setup.exe  or noatikl_win64_plugin_setup.exe

Run to install the 64-bit versions of :
noatikl.exe  (standalone)
noatikl_VSTi_win.dll  (VSTi plugin)

c:\Program Files\VstPlugIns

Important note: The Vst plugin is always installed to the \Program Files\VstPlugIns path shown
above (and to the drive Windows is installed to), irrespective of the editable folder destination
shown in the installer, e.g. “C:\Program Files\intermorphic\appname" where appname is the name
of the Intermorphic app whose plugin you are installing. The editable destination affects *only*
where the plugin uninstall files are put (e.g. unins000.dat and unins000.exe) so please leave it at
the default setting.

If you want to use the Noatikl VSTi, you might need to tell your Sequencer program to scan the
appropriate folder for the Noatikl VSTi, as above.

Configuring your Windows computer so that Noatikl can route its MIDI data

1. Install and enable loopMIDI (or other similar virtual MIDI router)
2. Proving loopMIDI works (e.g. in Cubase)

Create a MIDI project
On MIDI track 1 enter some notes with piano roll editor
Set "in:" to "Not Connected"
Set "out:" to one of the virtual MIDI ports.

https://intermorphic.com/noatikl/#faq-virtualmidiport
https://intermorphic.com/noatikl/index.html#downloads
https://www.apple.com/osx/apps/app-store.html
http://itunes.apple.com/app/id665202676
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On MIDI track 2 set "in:" to the same MIDI port.
Set "out:" to be your favourite VST Synth or sampler, e.g. "The Grand SE"
Press transport Play, and you should hear your MIDI events being rendered through a soft synth
where your MIDI events have been routed from one track to the other through the virtual MIDI
driver.

Sequencer-specific Plug-in notes

Reaper: How to use the Noatikl VSTi in Reaper
Sonar: How to route MIDI events from the Noatikl VSTi in Sonar
Cubase: How to use the Noatikl VSTi in Cubase
Ableton: How to use the Noatikl VSTi in Ableton

Noatikl 3 for Mac macOS: Desktop Audio Unit Plugin (AU)

The Audio Unit plugin does not require a Product Key, but instead a Mac App Store purchased and installed
version of Noatikl 3.

Garage Band 10 users: See the following - How do I use Audio Unit plugins?

The downloaded zip file is called noatikl_AU_mac.component.zip .
Unzipping it will extract the file noatikl_AU_mac.component
Copy or move this file to:

Admin password required:

Hard Disk/Library/Audio/Plug-Ins/Components 

Or (where tilde [~] in the pathname is a shortcut for your user account name):

~/Library/Audio/Plug-Ins/Components 

Configuring your Mac so that Noatikl can route its MIDI data

Use the following steps, which are also shown in one of the video tutorials:

1. Enable your IAC driver
Click on the blue magnifying class (spotlight) icon on the top right of your Mac screen
Type "audio midi setup"
Click on the Audio MIDI Setup entry you will see listed under applications. This will run the audio
midi setup application. Note: more advanced Mac users could use Finder to run this application
directly, you will find it under Applications / Utilities Audio MIDI Setup
Click on MIDI Devices tab
Click on IAC Driver
Click on Show Info icon
Ensure that "Device is online" is ticked, and press Apply

2. We strongly recommend that you download and use the excellent MidiPipe by SubtleSoft, which you
can get from http://www.subtlesoft.square7.net/MidiPipe.html ... a very useful piece of software, which
most of our Mac tutorials rely on! Please also refer to the Noatikl video tutorial - "creating your first
piece on Mac" which will get you going with MidiPipe in 1 minute.

Sequencer-specific Plug-in notes

Reaper: How to use the Noatikl VSTi or Noatikl Audio Unit (AU) in Reaper

https://intermorphic.com/noatikl/index.html#standalone_firstpiece_mac
http://www.subtlesoft.square7.net/MidiPipe.html
http://www.subtlesoft.square7.net/MidiPipe.html
https://intermorphic.com/noatikl/index.html#videos
http://thegaragebandguide.com/garageband-10-au-plug-in-fix
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Logic: How to use Noatikl AU in Logic
GarageBand: How to use Noatikl AU in GarageBand

Launching Noatikl 3

iPhone / iPad / iPod touch:
Tap the Noatikl 3 app icon in the App screen.

Desktop PC or Mac:
on Windows PC, select

Start > Programs > Intermorphic > Noatikl

on Mac run

Finder > Applications > Noatikl

Once launched, the load screen will display for a few seconds as Noatikl loads up and show status updates such as
"Loading skin" "version number " and "Loading content". Once Noatikl has loaded the load screen will disappear.

Windows Product Key

Noatikl 3 for Windows Product Key

Noatikl 3 Desktop Standalone & Desktop Audio Plugin (VSTi) for Windows are made available via our website
as 30 day trial versions. To continue to use the Desktop Standalone version after the 30 day evaluation
period requires that you purchase the Noatikl 3 Desktop Standalone licence from the Intermorphic webstore.
The Desktop Audio Plugin is provided "As Is" and is free to use once you have purchased the Noatikl 3
Desktop Standalone licence. Following your purchase you will be sent an Order Confirmation email that
contains your Order ID, Customer ID (the email you used for purchase) and Product Key, or in some cases
just a Product Key.

Noatikl 3: The Product Key for the Noatikl Desktop Standalone version and Noatikl Desktop Audio Plugin are
both the same. However, you must still enter your Product Key into each product to unlock it.

Noatikl 2: This had separate (different) Product Keys for the Standalone and Plugin versions, and each was
sold separately. To use the Standalone version requires the Standalone Product Key and vice-versa.

To enter your Desktop Audio Plugin product key, launch the Plugin from your Windows Desktop Audio
Workstation (DAW) or Sequencer that is a VST host (e.g. Sonar, Reaper, Ableton, Cubase etc) and then
follow the instructions below.

As you are entering your Product Key into a plugin on a Windows PC, then you might need to ensure that you
are running the host software (e.g. Reaper 3) "as Administrator" in order to get the product key to stick.

Entering the Product Key

Open your Order Confirmation email.
Launch Noatikl

Noatikl Desktop Standalone is launched as you would launch any standalone software.
Noatikl Desktop Audio Plugin must be launched via the VST host you are using it in.

From the Noatikl / Noatikl Plugin Main Menu select Help > Noatikl Product Key.

https://intermorphic.com/store
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From the Noatikl / Noatikl Plugin Main Menu select Help > Noatikl Product Key.
A dialog box will pop up, and you should copy the relevant information from your Order Confirmation
email (i.e. Customer ID, Order ID and Product Key or where only Product Key is provided, then just that)
and paste into the relevant fields. All information must be the same as that in your Order Confirmation
email and please ensure there is no space in front of or after the Product Key in the Product
Key field (which can happen when you paste it in). If you have problems, see this FAQ entry.
See also the Noatikl Plug-in for details on the Plug-in Extension Key (this is something different).

Copy Content In/Out (Backup)

This is right at the top of this guide because knowing how to transfer your files to/from devices to PCs is also key to
backing up your creative work. That is very important and thus needs to be easy to find!

Where is the "Intermorphic Folder" (macOS/Windows/Android)?

For Noatikl 2.3+ and Mixtikl 6+ ONLY

For Wotja 4 see iCloud / iCloud Drive

Tip: In Mixtikl 7 / Noatikl 3, to use App Files or Other Content from an earlier version, simply first move it to the
Intermorphic Folder (a *flat* folder).

Intermorphic Folder

Our Desktop Noatikl and Mixtikl Apps look for Zip Files and Other Content, where used and referenced in an
App File, in a specific folder. This allows such content to referenced/used in both mobile and desktop versions
of those apps. We call this folder the "Intermorphic Folder". It is a *flat folder* (where tilde [~] or
%HOMEPATH% in the pathname below is a shortcut for your user account name).

Mixtikl Note: The "User_Content" folder (Mixer > Mixer Cell > Content button, then ".." and scroll the list to see
it at the bottom) is an alias for the "Intermorphic Folder", and is the fastest way to see the files located in it.

The "Intermorphic Folder" is found here:

~/Music/Intermorphic/  (Mac)
%HOMEPATH%\Music\Intermorphic\  (Windows)
/Intermorphic/ (Android)

This is a folder that is at the top level of your *internal* storage card.
Note: Depending on your Android device this may also work with an external SD Card if Mixtikl is
also installed to that card.

Tip: If you are not sure where to find the Intermorphic Folder, use an IM App as follows:
Mixtikl: Try saving a .mixtikl or .noatikl file and then take a look to see what folder it appears in.
Noatikl (Desktop): From the Menu select Tools > Show Folders > Noatikl Files
If you want to use Other Content from an earlier version of Mixtikl or Noatikl, or even your own
content in IM Apps, simply move it to the above *flat* folder.
IMPORTANT: A flat folder means that *all content* must be at the top level of that folder. It must
not be in a subdirectory under it or it will not be found. So, for example, the free Tiklpak AL
Collections 1-3 zip file would just go here, alongside any mix files you might have saved or indeed
any other content e.g.: ~/Music/Intermorphic/IMTPALLoopEssentials1.zip

Tip for NT3+/MT7+: To keep things even tidier on Desktop, you can now create a ‘zips’ folder under the

https://intermorphic.com/tiklpak/#downloads
https://intermorphic.com/noatikl/#faq-productkey
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IM Folder above and simply copy your zip files to there, e.g.:
~/Music/Intermorphic/zips/IMTPALLoopEssentials1.zip . Files are still saved to the

Intermorphic Folder.

How do I transfer content in/out of Noatikl, make backups etc.? E.g. Files, SF2, MIDI recordings.

Important: iCloud-supporting Intermorphic Apps can use iCloud synching/backup for "App Files" only. "Other
Content" must still be backed up/transfered in/out via the "Intermorphic Folder" below. Refer also to the
Backup section at the end.

See the relevant sections below for details on what can be copied, e.g. "App Files" and "Other Content", what
IM Apps support iCloud and other useful information and links.

iOS <-> Mac / Windows PC:

Noatikl 2.3+ and Mixtikl 6+ (mobile and desktop versions)

See Apple's latest docs on iTunes Apps File Sharing for details on how to copy files (e.g. App Files
and Other Content) from iOS to/from Mac/PC and vice-versa.
Important iCloud Note : On first start up of an iCloud-supporting iOS apps any App Files that are here
will be moved to iCloud (if "iCloud" is selected in the pop up, rather than "Local Storage"). After that, no
App Files are saved here and App Files that are copied here will NOT appear in the relevant App's Files
screen.
Important note for App Files that reference Other Content: So that IM App versions (e.g. mobile,
desktop) know where to look for them, when copying Other Content (see below. e.g. WAV files) from
your device to your Mac/PC ensure you always put them in the Intermorphic Folder.
Tip: You may need to restart the IM App for it to be able to find any new content copied in.
Tip: You can also email yourself mixes and recordings, and then import from those, but that is
something that has to be done one file at a time.
Other Content is shown in the root directory in the right hand side list. Ignore folders called
"CompatibleAppsCache" and "intermorphic".
Mixtikl Tip: The "User_Content" folder (Mixer > Mixer Cell > Content List, then ".." and scroll the list to
see it at the bottom) is an alias for the "Intermorphic Folder", and is the fastest way to see the files
located in it (e.g. WAV files).
Mixtikl Tip: When WAV files are not in a correctly formatted Pak they will not be pitch shifted or time
stretched if you change the mix root or tempo.
See the following links for information related to Noatikl 2.3 (or earlier) Desktop (macOS/Windows) or
Mixtikl 5 Desktop (macOS/Windows).

Android <-> Mac / Windows PC:

Mixtikl 6+ (mobile and desktop versions)

Connect your Android device to your PC or Mac. It will appear in Explorer or Finder as a USB device.
With Explorer or Finder, on your device look for the Intermorphic Folder (see below, a top level folder
called "Intermorphic" (i.e. NOT /Music/Intermorphic/) on the *internal* storage card of your device).

Note: Depending on your Android device this may also be on an external SD Card if Mixtikl is also
installed to that card.

Copy your App Files and Other Content (see below. e.g. WAV files) to/from this Intermorphic Folder.

https://intermorphic.com/mixtikl/#oldAppPaths
https://intermorphic.com/noatikl/#oldAppPaths
https://intermorphic.com/tiklpak/guide/index.html
https://intermorphic.com/mixtikl/guide/index.html#contentList
https://intermorphic.com/mixtikl/guide/index.html#mixercell
https://support.apple.com/en-gb/HT201301
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The "User_Content" folder (Mixer > Mixer Cell > Content List, then ".." and scroll the list to see it at the
bottom) is an alias for the "Intermorphic Folder", and is the fastest way to see the files located in it
(e.g. WAV files).
Important note for App Files that reference Other Content: So that IM App versions (e.g. mobile,
desktop) know where to look for them, when copying Other Content (see below. e.g. WAV files) from
your device to your Mac/PC ensure you always put them in the Intermorphic Folder (see below).
Tip: When WAV files are not in a correctly formatted Pak they will not be pitch shifted or time stretched if
you change the mix root or tempo.
Tip: You may need to restart Mixtikl for it to be able to find any new content copied in.
Tip: When WAV files are not in a correctly formatted Pak they will not be pitch shifted or time stretched if
you change the mix root or tempo.
Tip: It is easiest to delete files on your Android device using Explorer or Finder but you can also delete
them using Menu > Tidy.
See the following link for information related to Mixtikl 5 (Android).

App Files:

These are saved by the relevant app with a filename corresponding to that of the app.

When you use iCloud in an iCloud-supporting app these files are all saved to iCloud (see the iCloud FAQ).

.noatikl, .mixtikl, .liptikl, .wotja

Other Content:

These are additional files that can be used by an IM app, including being referenced in App Files, and files
that can be exported/utilised by an IM App. They are not saved to iCloud and they must be backed up
separately.

Files that are exported/utilised by the app are stored locally in the Intermorphic Folder (see below).

It is strongly recommended that files that are referenced by your App Files should be put in the Intermorphic
Folder (see below).

Noatikl [NT2.5+]

Exported/Utilised: .fxm, .tg
Referenced: .Zip (Tiklpak/Pak), .SF2, .DLS

Mixtikl [MT6+]
Exported/Utilised: .WAV, .MIDI, .fxm, .tg
Referenced: .Zip (Tiklpak/Pak), .WAV, .Ogg, .SF2, .MIDI, .DLS

iCloud-supporting IM Apps:

Noatikl 3.1+ macOS, Noatikl 3.1+ iOS
Liptikl 2+ macOS, Liptikl 2+ iOS
Wotja 3.2+ iOS
Mixtikl 7.1+ iOS

iCloud Drive Folder (Mac):

Noatikl 3.1+ and Liptikl 2+ (macOS)

http://intermorphic.com/help/index.html#faq-icloud
https://intermorphic.com/mixtikl/#oldAndroidAppPaths
https://intermorphic.com/mixtikl/guide/index.html#tidy
https://intermorphic.com/tiklpak/guide/index.html
https://intermorphic.com/mixtikl/guide/index.html#contentList
https://intermorphic.com/mixtikl/guide/index.html#mixercell
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Our iCloud-supporting Desktop Apps for Mac allow App Files to be saved to and opened from the iCloud Drive
folder (see the iCloud FAQ). The folder on Mac macOS is found here:

~/iCloud Drive/Noatikl/  (Mac)
~/iCloud Drive/Liptikl/  (Mac)

Soundfonts (SF2) for IM Apps - where to put them:

You may want to use your own SF2/DLS (“SF2”) in mixes or pieces (“Pieces”) that can play in both Mobile and
Desktop IM Apps.

If you put and use your SF2 at the top level of the Intermorphic Folder (see above), any Pieces in any
App will find them just fine (tip: so that the App can find a SF2 after you have added it, always restart
the App).
Alternatively, if you have a lot of SF2 and you just want to keep things tidy under the Intermorphic
Folder, then, if, all the sf2 are in a flat folder you can just zip the SF2 files and then put that zip file
there.
Tip for NT3+/MT7+: To keep things even tidier on Desktop, you can now create a ‘zips’ folder under
the Intermorphic Folder above and simply copy your SF2 zip files to there, e.g.:
~/Music/Intermorphic/zips/mySF2Collection1.zip .

In any event, make sure you put the SF2 or zip file(s) there before you reference them in your Pieces!

Note : You select the SF2 you wish your Synth Network to use via the PSE Wavetable Unit. The Wavetable
Unit SF2 list is alphabetically sorted first on folder names (if present in a zip, see "Zipping with Folders" below)
and then on SF2 names.

Zipping with Folders (optional)

We appreciate you may have lots of SF2 you might want to use, or even collections of them and you want to
keep things tidy and structured on your PC or even in the Wavetable SF2 list.

You might wish to zip with folders if:

you want to have control over the order in which SF2 display in the Wavetable Unit SF2 list (i.e. you
might want to easily see all ‘synths’ in one block); or
you want to retain the structure of the SF2 grouping (perhaps you have licenced a collections or set
from a 3rd party and it is already set out like that)

Say you have the following collection of SF2 files that you want to use in an App (and want to show up in the
Wavetable Unit SF2 list like this, too):

mySF2Collection1/drones/drone1.sf2

mySF2Collection1/pads/pad1.sf2

mySF2Collection1/synths/synth1.sf2

To retain that structure you must zip the above directory *such that it keeps the entire folder paths*. You can
give this zip any name, maybe something like “mySF2Collection1.zip”

In macOS you can create this zip by right clicking the "mySF2Collection1" folder and selecting “Compress
'mySF2Collection1'”. Alternatively, in Terminal, navigate to the folder above this folder and type:

zip -r mySF2Collection1.zip mySF2Collection1

You can check that the zip has the files you expect in it by typing in terminal:

https://intermorphic.com/pse/3/index.html#tg-wavetable
http://intermorphic.com/help/index.html#faq-icloud


12/61

unzip -t mySF2Collection1.zip

Now, put this zip file *at the top level* of the Intermorphic Folder, restart the App and then create and save
Pieces that reference these SF2. If you then move those Pieces between Apps, they should still play just fine
(provided you have copied that zip file in of course!).

Backing up:

Note: Using iCloud as your App File backup mechanism is very convenient. It also keeps them in sync across
devices and so makes it easy to work with those files in the iOS version of that app.

App Files on Mobile Device :
If you are using iCloud then we still recommend you occasionally back up your "App Files" that
are in the "iCloud Drive" folder. Reason?: Just in case!
If you are NOT using iCloud for your App Files (meaning they will be stored locally on your
device) we strongly recommend you regularly back them up to an "Intermorphic Folder" on
that Mac/Windows PC. You should certainly do this BEFORE you remove an IM App from your
device as the process of removal also removes ALL of the Apps' locally stored files.

Other Content on Mobile Device : If you have a Mac/Windows PC we strongly recommend you use
it to regularly and separately back up your "Other Content" to an "Intermorphic Folder" on that
Mac/Windows PC. You should certainly do this BEFORE you remove an IM App from your device as the
process of removal also removes ALL of the Apps' locally stored files.
iOS specific note : Although making an iTunes backup of your device will back up all your installed
apps AND their locally stored data (see: http://support.apple.com/kb/ht4946), if you remove  and then
reinstall an app, its local DATA is not restored: the only way to get back that app's local data is to do a
device restore from a backup (See: http://support.apple.com/kb/HT1766) - but that also then
OVERWRITES ALL device app data with whatever was in the backup. If you want or need to go that
route, see this FAQ entry.

 Remove Noatikl

Note: If you want to remove Noatikl so you can reinstall an older version, see the instructions here.

iPhone / iPad / iPod touch:

In the App screen tap and hold the Noatikl application icon, and then press the jiggling black cross in the left
corner of it.

PC:

Select the corresponding Uninstall item

Start > Programs > Intermorphic > Noatikl >

Mac:

With Finder, locate the following folders:

1. Hard Disk/Applications

Drag Noatikl  to the Trash

https://intermorphic.com/noatikl/#faq-reinstall-older-version
http://intermorphic.com/help/index.html#faq-ios-itunesrestore
http://support.apple.com/kb/HT1766
http://support.apple.com/kb/ht4946
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2. Hard Disk/Library/Audio/Plug-Ins/Components

Drag noatikl_AU_mac.component  to the Trash

 Quick Start

The following short text tutorials are to get you started fast, doing some very basic things with minimum fuss. The
principles are the same for both Noatikl Desktop and Noatikl Mobile (even if slightly different).

Noatikl is a very deep app and quick tutorials are no substitute for further investigation - they are just to get you
started! To that end, in most steps we link to further information where you can go on to read and learn more about
various screens and what they are for.

Tutorial 1: Open, Play a Piece; add a Template Voice; Save piece

1. Launch Noatikl
2. Open a piece:

Mobile : From the Files Screen tap on a file to load it and the piece will open in Design View.
When installed, Noatikl 3 iOS should come with some demo pieces pre-installed; If these
files are for some reason not there then if you have access to a desktop computer and
iCloud Drive you can download a zip of them from here and then just unzip that in the
iCloud Drive folder.

Desktop:
Menu > File > Open and the select a file.
When installed, Noatikl 3 should add some demo pieces to the Intermorphic Folder : Mac
macOS ~/Music/Intermorphic/  and Windows: %HOMEPATH%\Music\Intermorphic .
If these files are not there you can download a zip of them from here and then just unzip
that in the Intermorphic Folder or iCloud Drive folder.
Mac OS Tip: Were you to already have pieces saved locally and you use iCloud, then
Noatikl 3 will likely save these to the iCloud Drive folder.

3. Play the piece:
Mobile : Tap the Play/Stop toggle button in the bottom toolbar
Desktop: Tap the Play/Stop toggle button in the top toolbar

4. Add a Template Voice:
Mobile :

Tap the + button in the bottom toolbar (next to Play/Stop toggle).
In the pop up list, tap any Pak on the left of the list (e.g. "IM3_Drones") and on the right tap
a content item (e.g. "Choral lowfi"), which also previews that item (or select Pak "Noatikl
Seed" if you want to add a new default Voice of one of the 5 Voice Types).
Tap the top right Merge item and press OK to add it to the existing piece.

Desktop:
Select any parameter of a Voice you want to add a new Voice AFTER.
Select Menu > File > New to see the list of Templates available (or select Menu > Edit >
Add Voice to add a new default Voice)
Tap a content item in the Template list which also previews that item, and then tap the
Merge button to add it to the existing piece.

5. Save your piece :
Mobile : Tap top left Menu icon and you will see the Files Button Popup where you can decided
what to do next on the way back to the Files Screen. In the Files Screen, tap on the file name with

https://intermorphic.com/noatikl/guide/index.html#noatikl-mobile-design
https://intermorphic.com/help/index.html#faq-icloud
https://intermorphic.com/help/index.html#faq-icloud
https://intermorphic.com/download/content/demos/NT3-demo-pieces.zip
https://intermorphic.com/help/index.html#intermorphicfolder
https://intermorphic.com/help/index.html#faq-icloud
https://intermorphic.com/download/content/demos/NT3-demo-pieces.zip


14/61

"untitled" text in it and enter a name for the piece ("MyPiece"), and then press the OK button.
Desktop: Select Menu > File > Save, enter "MyPiece" in the Save As field and find the folder to
save it to iCloud folder or the Intermorphic Folder or the iCloud Drive folder as preferred or
appropriate to you.

Tutorial 2: Make a New Piece; assign MIDI channel; change the sound; change track/global FX

1. Launch Noatikl
2. Create a Piece:

Mobile : From the Files Screen tap the Create New "+" icon. Tap Standard Templates Pak on the
left, tap Simple File template on the right and then tap the top right New button and you will be
returned to the Design View with a new piece based on that template. Press Play to hear it.
Desktop: Select Menu > File > New to show the template list and from Standard Templates select
the Simple file template; press the New button at the top of the template list to be returned to the
main screen with a piece based on that template. Press Play to hear it.

3. Assign MIDI channel (optional, as MIDI channel 1 should already be assigned): Tap and hold the Voice
on the left and drag to the MIDI channel 1 box to the right (as you drag all of the MIDI channel boxes will
become visible).

4. Change Wavetable SF2 sound: Tap the Synth box (to the right of the MIDI box) to launch the Partikl
Network Editor and in that tap the purple box marked "1 Wavetable". In the left hand SF2/DLS drop box
select IM Synths and in the right Patches drop box select "11-VoxA" and press the top left button twice
in a row (Desktop: "OK"; Mobile: "MIDI 1 Synth", then "Design") to return to the Design Screen with your
new sound.

5. Change Track FX: The Track FX (if any) is applied to just the track. Tap the FX box (to the right of the
Synth box) to launch the Partikl Network Editor and in that tap the Folder button (Desktop) or Action
button, then Open (mobile) to open the FX preset list. Select "Chorus default" and press the top left
"OK" button (Desktop) or "Design" button (Mobile) to return to the Design Screen with your new FX.

6. Change Global FX: The Global FX (if any) is applied to the whole piece and it's operation is just like a
track FX, above. Tap the Glob FX box (to the right of and above all the tracks) to launch the Partikl
Network Editor and in that tap the top toolbar Folder button to open the FX preset list. Select "Reverb
default". Exit this screen as above.

7. Save your piece: Follow the instructions in the first tutorial and save to "MyPiece2"

Tutorial 3: Change track volume/pan; track mute/solo; change pitch; export a piece

1. Launch Noatikl
2. Open the piece "MyPiece2" you saved in Tutorial 2 and play it.
3. Change track volume/pan:

Either:

Both: Tap the Track FX button and enter the "Amp" unit that you will see after the Chorus unit.
Change the Level slider to suit (Tip: If you want to change the volume level for the whole piece,
just go into the Global FX and add an Amp unit at the end by tapping to the right of the last FX
unit and selecting Amplifier in the pop up list), or;

Mobile : Tap the bottom tab bar Blend icon to go to the Blend View, then drag the Voice
icon around the screen to change its volume (up/down) and pan (left/right).

https://intermorphic.com/pse/3/index.html#networkeditor
https://intermorphic.com/help/index.html#faq-icloud
https://intermorphic.com/help/index.html#intermorphicfolder
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Desktop: In the left hand side Parameter Group display select the "Voice - User Env 1-
Volume" parameter group. In the Envelope parameter control shown on the right, either
draw on it with your mouse, or right click on it and select one of the options. Pan: Select the
"Voice - User Env 1 - Pan" parameter instead and change the Envelope parameter control.

4. Change track mute/solo:
Mobile : In the Blend View, tap on a Voice icon and from the pop up control select either Mute or
Solo. Tip: You can also use the Mute or Solo button in the bottom toolbar.
Desktop: Check or uncheck the Mute parameter or, to solo just one Voice, select and hold the
keyboard Control key when you select the Mute parameter.

5. Change Voice pitch:
Mobile : Tap on a Voice icon and from the pop up control select Edit to enter the Voice View. Tap
the left hand Basics group and then in the right of the screen scroll to find the Pitch parameter
and use the slider or +/- control to change it. Tap the bottom Degin tab to return to the Design
View.
Desktop: In the left hand side Parameter Group display select the "Voice - Basics" parameter
group and then in the right hand side parameter grid change the value of the Pitch parameter
using +/- control or just type a value in that parameter's grid cell.

6. Export a piece:
Mobile : Tap top right "Action" icon and choose how you want to export it!
Desktop: Select Menu > File > Export and chose whether to "Export as mail" (a file attached to
an Email) or "Export" which copies it to the clipboard.

 Noatikl Desktop [DT]

Noatikl Desktop comes in Standalone and AudioPlugin (VSTi / AUi) versions. It is a deep product and it does take
time to master - but it is worth the effort. This section will go though the main areas of the desktop interface so that
you can become familiar with what does what and we will go on from there.

Note: do also check out Noatikl Mobile, which has the majority of the power of Noatikl Desktop.

Before you start ...

Ensure you have installed Noatikl Desktop and have it correctly setup for MIDI Out if you wish to use that. If you use
Logic, also note the special instructions for Logic.

OK, let's get going!

When you first load Noatikl Desktop you see the following screen which gives you some quick pointers on what to
do next:
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Noatikl Start screen

Playing your first piece

Noatikl comes with several demo pieces for you to try out. In the Desktop versions these are installed to the
"Intermorphic Folder". Once you have finished with them you can delete them if you want. If you want to get them
back again, just download a zip of the demo pieces and unzip that in the Intermorphic Folder.

To load and play them, from the menu select File > Open. Once the piece has loaded, just press the Noatikl Play
button and enjoy!

https://intermorphic.com/download/content/demos/NT3-demo-pieces.zip
https://intermorphic.com/noatikl/guide/index.html#copyinout
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Noatikl Desktop UI

The screenshot above was taken of Noatikl playing the "Demo - Cosmic" piece and it contains a number of
generators (voices). This helps illustrate the different areas in the Desktop interface.

Control Bar

The top "Control" bar contains the Play/Stop button (press Play to hear Noatikl), as well as information on piece
progress, and fast access to some key MIDI options (as these are very important for many Noatikl users).

Play and Stop

Noatikl Standalone Play
The Play button starts you playing. You will only see this button for Noatikl standalone; for the plug-in
variants of Noatikl, play/stop is controlled directly by your DAW (Digital Audio Workstation)'s transport
controls.

Note: you might first want to set-up a MIDI device through which to render your music. See MIDI Routing or
MIDI Output for more info on this.

Note: if you have Sync? selected, then playback won't start making any sounds until the sequencer that you
are listening to has the play button pressed on its own transport control. In this case, you must first press
Play before Noatikl can respond to events from your sequencer's transport control.

Noatikl Standalone Stop
The Stop button stops you playing. You will only see this button for Noatikl standalone; for the plug-in
variants of Noatikl, play/stop is controlled directly by your DAW's transport controls.

Noatikl Plug-in Play and Stop
Press the Play This File! checkbox to indicate which of your open documents is to be played in response to
the Transport control in your DAW. Remember that Noatikl can have more than one document open at once,
so this checkbox tells the DAW which of the open Noatikl files to play.

Progress indicators

When the piece is playing, you will see various interesting properties get displayed in the Playback group:
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Tempo
This shows the current Piece tempo. If you are using one of the Noatikl Plug-in variants, then this value will
be the value that is forced by the sequencer host in which Noatikl is running.

Elapsed
The elapsed time in Measures:Beats:Ticks format (MBT).Note that if you are using of of the Noatikl Plug-in
variants, then this value might be up to a bar ahead of the value displayed by your sequencer's transport
control; this is because Noatikl composes ahead according to a latency dictated by the behaviour of your
host sequencer.

Percent
The approximate elapsed Noatikl Piece position, relative to the Piece Duration.

MIDI Output

Whether or not you have "Partikl?" checked (which allows sounds and FX to be rendered via the PSE), you can
optionally ask Noatikl to deliver MIDI event data from the Voices in your piece to a MIDI Output device.

If you are running within a sequencer which does not support MIDI routing from one VST to another then you must
select any value other than "Sequencer MIDI Pipeline" (otherwise your MIDI events will not generate any sound in
the sequencer).

If you are using some other VST Host which allows MIDI data to be routed from one VST into another one (e.g.
Reaper), then you may select any of the available options; though you are most likely to want to select the
"Sequencer MIDI Pipeline" option.

Standalone
Mac: select an IAC port, and maybe use MidiPipe by SubtleSoft to render your audio data. Please refer to the
Noatikl video tutorial - "creating your first piece on Mac" which will get you going in about 1 minute.

Windows – use a MIDI output device; use MIDI Yoke or Maple if you want to route data from Noatikl to your
DAW!

Plug-in
In general, use the "Sequencer MIDI Pipeline" option.

Audio Unit (AU)
See listed IAC Driver Bus 1 (this assumes you have configured the IAC as outlined above) and
perhaps some other devices.

VST
Mac: See "Sequencer MIDI Pipeline" followed by Mac - IAC Driver Bus 1
Windows: Use Microsoft GS Wavetable SW Synth or perhaps some other MIDI output devices
such as MIDI Yoke channels.

MIDI Input

You can tell Noatikl to listen-out for incoming MIDI data on the specified port. Noatikl can use incoming MIDI
information for various purposes, including synchronisation and as a hyper-instrument through Listening Voices.

Checkboxes

Partikl?

By default, the "Partikl?" checkbox is ticked. This means that Noatikl will play the MIDI events generated by
the generative Voices, through the built-in PSE.

If you tick the "Partikl?" checkbox, and have no MIDI Output device specified, Noatikl will send data only
to PSE.

https://intermorphic.com/pse/3/index.html
https://intermorphic.com/noatikl/index.html#standalone_firstpiece_mac
http://www.subtlesoft.square7.net/MidiPipe.html
https://intermorphic.com/pse/3/index.html
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If you tick the "Partikl?" checkbox, and set a MIDI Output device, Noatikl will send data simultaneously
to both PSE and your MIDI Output device!
If you clear the "Partikl?" checkbox, Noatikl will only deliver its MIDI output to whatever MIDI Output
device you have specified - in this case, make sure you have a MIDI Output device specified, or you
won't hear anything!

Sync?

You can use the Sync feature to allow Noatikl (when playing through an external MIDI device or port) to
synchronise with audio playback in your favourite Sequencer. Once this checkbox is selected, then playback
won't start making any sounds until the Sequencer that you are listening to has the play button pressed on
its own transport control.

Note: you will experience a degree of MIDI latency (i.e. all notes offset by a certain amount) and some small
variation in the note playback timing (typically +/- 5 or 10ms). We are looking at ways to minimise this in later
updates. If you record the Noatikl output to a MIDI file, then it is fairly easy to adjust for the latency and also
quantise (if you want) the note timing.

Noatikl Standalone
Check the "Sync?" checkbox and set your Noatikl MIDI input device to listen-out to the MIDI port to
which you have told your Sequencer to send MIDI sync information.

Press the Noatikl Play button.

Noatikl will then start and stop playing automatically in response to your pressing the play and stop
buttons in the Sequencer.

For an example of setting this us see also this FAQ entry.

Note: Noatikl does not currently support "Resume", so if you press "stop" in your sequencer,
then to restart Noatikl you will first need to rewind your sequencer head to the beginning before
pressing "play".

Noatikl Plug-in
Press the play / stop buttons in your transport control.

MIDI Sync using Logic:
Using Logic Pro on the Mac, you can use MidiPipe by SubtleSoft to provide the "cabling" between
Noatikl and Logic. Please refer to the Noatikl video tutorial - "creating your first piece on Mac" which will
get you going in 1 minute. Set-up couldn't be easier.

1. Set noatikl's in and out ports to MidiPipe, engage the Sync? option and hit play in noatikl.
2. Open Logic, set the sync option to send midi clock to the MidiPipe port and that's it really. Once

you've done that, the Logic transport controls work both Noatikl and Logic - hit play in Logic and
Noatikl starts composing and feeding the tracks in Logic with midi data. What you do with it then
is up to you. Control the tempo of the piece live in real-time from Logic's transport. Or, if you
have them, you can use a hardware transport controller!

Note for Logic 8 Users:
To use MIDI sync in Noatikl AU for Logic 8:

1. Just connect-up IAC1 in the click and port layer... i.e. remove the SUM option... if you don't use
the SUM input you need to connect input ports on a port by port basis. Needs good eyesight
and a steady hand if you have a lot of ports.

2. project MIDI sync settings to send to IAC port 2.
3. noatil file: set output IAC1, output IAC 2, sync = checked.
4. Should then work OK.

https://intermorphic.com/noatikl/index.html#standalone_firstpiece_mac
http://www.subtlesoft.square7.net/MidiPipe.html
https://intermorphic.com/noatikl/#faq-sequencermidisync
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Listen?

This is provided to protect against MIDI feedback, which can occur with some sequencers, notably Logic
(which will by default present all data output to a port, as an input to all other ports).

If Listen? is ticked or if Noatikl is using the Plug-in internal sequencer pipeline, then:
MIDI events from the MIDI input will be passed-through to Noatikl
the MIDI Input trigger scripts will respond to MIDI input
listening voices will compose where appropriate
all note on/off events presented at the input will reach the output.
Noatikl will try to harmonize with incoming MIDI note data.

If Listen? is not selected and if Noatikl is not using the internal sequencer pipeline, then:
MIDI events from the MIDI input will not be passed-through to Noatikl
MIDI Input trigger scripts will not respond
Listening Voices will not compose
the only events that will be passed through to Noatikl will be MIDI Sync events
Noatikl will not try to harmonize with incoming MIDI note data.

Noatikl 1.5+, Logic and midi feedback
Noatikl V1.5+ listens to incoming MIDI data to allow you to create dynamic hyperinstruments. In
order to use this feature in the standalone version of Noatikl, Logic users are advised to take
the following steps to eliminate the risk of midi feedback.

Voice / Generator Network Editor

The central "Generator Network" editor / panel is where you marry voices (note generators) to MIDI channels, PSE
synth sounds and FX. It shows a view of all NME Voices, together with cells showing the associated MIDI channel
and any PSE Synth, Track FX and Global FX settings. Refer to the NME Guide for information on Voice and Piece
parameters and the PSE Guide for information on Synth and FX parameters and Networks.

This panel lets you:

Drag Generators/Voices around for easy re-ordering (reflected in the Parameters area, below)
Drag Generator/Voice to MIDI Channel (or vice-versa) for easy MIDI channel mapping
Drag Generator/Voice to Generator/Voice for easy Follow/Repeat voice networks
Tap Synth/FX buttons to display the built-in PSE Synth/FX Network Editors

If you drag from a Voice box to a MIDI channel box that will tell the system that the Voice will play through the
defined MIDI channel. If a new voice is added to a piece, the voice won't be assigned to a specific MIDI channel; if
you haven't yet hooked-up a Voice to a MIDI channel, Noatikl will decide on a free MIDI channel to hook-up the
Voice to when it starts playing.

Patch and MIDI Channel
The Voice "Patch" parameter defines which MIDI Patch command to send for each MIDI channel - in general,
you should only hook-up multiple Voices to the same MIDI channel if they all share the same Patch
parameter.

MIDI Channel 10
MIDI Channel 10 is reserved for the Drum instrument. Every voice with a Drum Patch, should generally be
attached to MIDI Channel 10.

Synth
If the "Partikl?" checkbox is checked, then MIDI events are routed for each channel through a PSE
configuration defined by the associated Synth box, which by default will use the PSE's built-in MIDI Wavetable
synth (using the Patch defined by the Voice's Patch parameter). If you want to use a custom sound, click the

https://intermorphic.com/pse/3/
https://intermorphic.com/pse/3/index.html
https://intermorphic.com/nme/3/
https://intermorphic.com/nme/3/#generator-network
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Synth button to invoke the Synth editor dialog.

Track FX
The output from every Synth box can be passed through a custom PSE FX Network. If you want to use an FX,
click the FX button to invoke the FX editor dialog!

Global FX
The output from every PSE FX is added together and passed through a Global FX network. If you want to
use a Global FX, click the "Glob FX" button to invoke the Global FX editor dialog. This dialog looks the same
as for the Track FX dialog.

By default, the dialog shows no FX units. You can alter the network to use a custom set of sound FX units in
various configurations; or select from a list of built-in preset FX.

Object Type View

The left view lets you select which type of NME Objects you want to edit the parameters for in the Parameter panel
below.

NME Voice Objects
This is probably the most important Object Type in
Noatikl. A Voice is a Noatikl object that represents a
generator of Music data. For example, a Voice can be
used to play a fixed musical pattern. Or, a voice can be
used to create notes according to various musical rules.
A Voice can also be used to emit MIDI controller
information that is used to control your favourite
sequencer. You must have at least one Voice in your
Noatikl composition but you may have many more if you
want. The basic behaviour of a Voice is defined by its
Voice Type property. You may tell Noatikl that individual
Voices use specific Scale Rules (other any other of the
supported Rules).

NME Rule Objects
Scale Rule, Harmony Rule, Next Note Rule and Rhythm
Rule. These rules provide the settings that govern what
notes are composed, and when. Each Voice object can
use it own rules, as well the Piece Rules object (below).

NME Piece Objects
There is always exactly one Piece object in your Noatikl
composition. The Piece object manages various high-
level properties of your composition. These include things
like what musical rules to follow by default (where not
overridden by individual Voices), the Tempo to follow,
and various other global properties.

NME File Objects
You can store certain basic bookkeeping information
related to your file, such as the title of the composition
and the author. The File object doesn't define any data
that affects what you hear in your composition.

https://intermorphic.com/nme/3/#file
https://intermorphic.com/nme/3/#piece-basics
https://intermorphic.com/nme/3/#the-rules
https://intermorphic.com/nme/3/#voice-types
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NME Parameters View

The bottom "Parameters" view contains a table where you
can view and edit all of the NME Objects and Parameters
that make-up your Noatikl composition. It gives you

access access to all the editors for the group of objects and parameters you select in the left panel. In the above
picture, the Voices are listed together with their basic parameter values. Voices will flash here to show that they are
playing a note.

You can add Voices (or other musical objects) within the table, so that each row represents a different Voice, and
each column represents a different attribute of that Voice. Use the menu items to add, delete and copy voices and
other objects.

 Desktop Menus

File Menu

Note: If you are Noatikl for macOS, Noatikl 3.1+ for iOS and also use iCloud, then you might find it best to put your
files in your Mac's the iCloud Drive folder. You can open and save to that folder and it means you can easily sync
your Noatikl files between macOS and iOS devices that share the same iCloud account. See the iCloud FAQ.

New
Creates a new piece for editing; select the template that you want to use as the basis for your new piece, via
the dialog that is presented to you. Which templates get listed, depends on which template packs you have
got installed.

Merge...
Browse for a Noatikl template file to merge into the currently open piece.

From the list of templates, browse for a template that you want to merge-in to your current piece;
Noatikl does the "right thing", pulling in all voices and rules from that template (it does *not* replace
any rules, but will bring-in rules that do not currently exist in your piece); copies-in all voices and
renames each voice if required to keep them unique. Try merging in one or more drum templates!

Open...
Browse for a Noatikl or Partikl file to open.

Merge...
Browse for a saved Noatikl piece to merge into the currently open piece.

This is a similar operation merging in a Templates (see New > Merge above), except this will let your browse
for a Noatikl file that you want to merge-in to your current piece. Try taking any piece, merging-in any other
piece, and amaze yourself at what you hear.

Close
Close the currently open piece.

Save
Save your document as a Noatikl file with its current name in its current folder location.

Note: Noatikl 2 supported both the .noatikl and .partikl file format. Noatikl 3 supports the .noatikl file format
but can still open older .partikl format files.

Save As...
Save your document as a Noatikl file with a new name or folder location.

Tip: Making/saving your own templates

Object Type View

https://intermorphic.com/help/index.html#faq-icloud
https://intermorphic.com/nme/3/#scripting-objects
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To create a new Noatikl file which can be used as a template, perhaps one based on the Scale
Rules template to which you have added some of your own rules added, simply save this file e.g.
My_Scale Rules.noatikl and then zip that file e.g.My_Scale Rules.zip and place it in the
Intermorphic Folder or zips sub-folder. You can then re-open this whenever you want, and know
that it won't be overwritten.

Import
Import a Noatikl document from the clipboard.

Import Merge...
Import a Noatikl document from the clipboard and merge it into the currently open piece.

Export...
Export your Noatikl file to the clipboard.

Export as Mail...
Export your Noatikl file as an Email attachment.

Open Recent
Open from a list of your recently accessed Noatikl files (not available in the Mac standalone version).

Edit menu

Use the Edit menu items to copy and paste object parameters. The menu items available under Edit are as follows:

Undo
Where possible, Noatikl presents an Undo option.

Redo
Where possible, Noatikl presents an Redo option.

Add Voice
Adds-in a new default object of the currently viewed type.

Cut Voice
Cuts the currently focused object.

Copy Voice
Copies the currently focused object.

Copy Parameter
Copies the currenly focused parameter.

Paste Voice
Pastes in the most recently copied or cut object or parameter.

Delete Voice
Deletes the currently focused object.

Default Parameter
Restores the currently focused parameter to its default value.

Default Column
Restores all parameters in the currently focused column to their defaults.

Default Row
Restores all parameters in the currently focused row to their defaults.

Control menu

Use the Control menu items to play / stop tracks. The menu items available under Control are as follows:

https://intermorphic.com/noatikl/guide/index.html#intermorphicfolder
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Play / Stop
Starts or stops the piece playing (you can also use the Ctrl+Spacebar shortcut).

Solo Voice
Solos the selected voice.

Unmute All Voices
Unmutes all voices.

Mute All Voices
Mutes all voices.

Tools menu

Use the Tools menu items to access integrated helper utilities. The menu items currently available under Tools are
as follows:

Noatikl Script Window
Displays the Noatikl script window.

MIDI File Cooker (a file must be open)
Launches a utility to capture (as fast they can be generated) a user configurable number of takes to
sequentially numbered MIDI files. For MIDI file saving, see also Preferences.

Start/Stop
Starts off/stops the "cooking" process (make sure you
have a Noatikl file loaded, and have set the number of
"Files to Create" and "Record MIDI files to folder"
below).

Close
Closes the dialog.

Files to Create
Use the slider to select a number from 1-100 (or
double click the number field to enter a number).

Recorded Files
Tells you how many MIDI files have just been
recorded.

Recorded
Tells you the total size of the MIDI files that have just been cooked.

View
Uuse this button to see the folder where the recordings are saved.

Important note: when cooking a MIDI file, the tempo comes from the NME Piece Tempo parameters; not from
any host sequencer.

Show Folders
Show Noatikl Files (Music -> Intermorphic)
This is the folder under which Noatikl saves and opens all files, including your custom Synth and FX
networks, unless you are using iCloud.

Noatikl MIDI Recordings
Shows the folder where Noatikl saves MIDI recordings.

MIDI File Cooker

https://intermorphic.com/nme/3/#piece-tempo
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Options menu

Check for Updates when Noatikl starts (not available in the Mac Standalone version)
Select this to allow Noatikl check the Intermorphic website for a simple text file to let it know if there is
an update available.

Reset Column Widths
Resets the column widths for every parameter, to their default values.

Output Devices
Select your Output audio device to be targeted by Noatikl's built-in PSE synth.
macOS Important Note: If you wish to play Noatikl via AirPlay, and that is supported by your Mac, you
must set your Mac to play via an AirPlay Output device (Opt+Click on your Mac's system volume
control) and then restart Noatikl and then select that AirPlay output in Output Devices.

Help menu

Online User Guide
Noatikl Forum
Online Licence
About Noatikl

macOS: see Noatikl 3 > About
Noatikl Product Key

Windows versions only

Preferences menu

Mac: Noatikl 3 > Preferences...

Windows: Options > Preferences...

Plug-ins: Options > Preferences...

Use the relevant Preferences menu item to define the key settings that the way that Noatikl works. These include
settings for MIDI CC Events, and also to allow automatic MIDI recording of a live playback (see also Tools), as
follows:

MIDI Events
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MIDI Events

Send all CC Events - If you clear this checkbox, the only
MIDI CC events sent by Noatikl will be Bank Select (for
patch selection), and those from Micro Controllers and
User Envelopes. The reason for this is to (optionally)
suppress most of the CC messages that Noatikl sends
out as some synths don't seem to like them.

Automatic MIDI File Recording

Automatically record to MIDI files? - use this checkbox to
enable automatic recording of Noatikl output to a MIDI file
- select the tick box to enable this behaviour.
View - use this button to see the folder where the
automatic MIDI file recordings are saved.
Note: You wouldn't want to set the auto-record toggle
button if you were using Noatikl for an installation!
Note: when auto-capturing a recording through this
preferences setting, where the tempo comes from
depends on what configuration you are currently using:
- Noatikl Plug-in: the tempo comes from the host
- Noatikl Standalone synced to host:, the tempo comes
from the host
- Noatikl Standalone unsynced: Noatikl provides its own
tempo from the from the NME Piece Tempo parameters

Miscellaneous

Show Noatikl 2 Content - Check this to display all the
templates that were included in Noatikl 2 in the template

list (see File > New).

Plug-in

Refer also to the Plug-in section.

Global Harmonization - "Global" Scale Rule will be shared - It can be very useful when using the Plug-in in a
multi-instance configuration (i.e. more than one instance of the Plug-in is playing at the same time) to have
all plug-in instances harmonise together, i.e. some form of co-dependent composition. This checkbox allows
Scale and Harmony rules in the first piece that have the special name of "Global" AND that are used at the
piece level to be used as the relevant rules in all other pieces being played. i.e. A piece level scale rule
named "Global" in Plug-in instance 1 will then overide all other voice rules in all other pieces in all other
playing instances. Note: When a piece restarts it may take a few seconds for the Global rule(s) to override its
own rules.
Piece with Global Scale Rule forces Root - This checkbox forces the Root of the piece containing the Global
Scale Rule to be the Root used by all instances.
Strict Global Harmonization - This checkbox forces each composing instance to harmonize against a number
of previously composed notes, helping to ensure a harmonic coherency across instances.
Enable Playlist - This checkbox is greyed out unless you are using a Plug-in Extension Key that enables
playlist operation. If you have loaded multiple Noatikl pieces into the plug-in (displayed as tabs), this
checkbox allows random selection of the next piece once the current one has finished playing.

 Plug-in [DT]

Preferences Menu

https://intermorphic.com/nme/3/#piece-tempo
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 Plug-in [DT]

The Noatikl 3 Desktop Plug-in for Mac (AUi) and Noatikl 3 Desktop Plug-in for Windows (VSTi) are both free for
Non-Commercial Use for those who have purchased and installed the respective Desktop Standalone versions from
the Mac App Store or Intermorphic Web Store.

Under Non-Commercial Use we allow making recordings for Commercial Use, but for the avoidance of doubt we do
not include live generation of music for Commercial Use.

The Noatikl Plug-ins can be downloaded from our website and are provided "As is". Just like the Desktop
Standalone versions they have a Music End Time of 32,000 seconds (nearly 9 hours, and the maximum value of
the Piece Length parameter). The Plug-ins support up to 2 concurrent instance operation in a 3rd party licenced
DAW.

Once installed, Plug-in activation is as follow:

Windows version (30 day trial): From the Noatikl Plug-in UI in your DAW go Menu > Help > Noatikl
Product Key and enter the Product Key you received on purchasing a licence for the Windows Desktop
version.
macOS version: Activated by detecting an installation of one of the macOS Deskstop Standalone version.
To check it is activated, from the Noatikl Plug-in UI in your DAW go Menu > Help > Check Noatikl Plug-in
Activation.

See also the Noatikl Preferences menu which allows special modes of operation for the Plug-in(s).

The forgoing capabilities should be plenty for anyone wishing to make music with it in a non-commercial capacity.
However, if you need to do more, it is possible to extend certain capabilities: see below.

Commercial and Extended Use

The Noatikl 3 Desktop Plug-in V3.3.3+ allowed extension of the Music End Time, additional concurrent instances
and playlist capability. This was principally intended to support a range of Commercial uses and was through the
provision of a separately paid for and specially generated Extension Key (both varying according to specific
requirements). This facility is now no longer being offered by Intermorphic as we are transitioning to Wotja, which
already includes playlist capability, and we are recommending MIDI output to control external synths and
environments.

 MIDI Routing [DT]

If you want to send MIDI output from Noatikl to a MIDI port or device, you will need to redirect the "MIDI Output" from
Noatikl using a technique appropriate to your version of Noatikl.

Mac: use an IAC MIDI port; this is built-in to every Mac. As an alternative, you could use MidiPipe by
SubtleSoft.
Windows: you might wish to try loopMIDI (see our FAQ entry).

If you are using a DAW/Sequencer, you must also assign one or more MIDI tracks to listen-out to the port to which
you are directing your Noatikl output! Note that for quick testing of this approach on Windows, you have the option
of directly targeting your built-in Windows wavetable synth.

You'll find a lot of information on how to configure the various variants of Noatikl in the Noatikl FAQ.

What Sequencers support direct sending of MIDI data from Noatikl, onwards to other
Instrument Plug-ins?

Reaper for Mac and Windows:

https://intermorphic.com/noatikl/faq
https://intermorphic.com/noatikl/#faq-virtualmidiport
http://www.subtlesoft.square7.net/MidiPipe.html
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Reaper supports pass-through of MIDI events generated from VSTis
Relevant Noatikl versions:

noatikl.app (Desktop Standalone, macOS)
noatikl.exe (Desktop Standalone, Windows)
noatikl_AU_mac.component (Audio Plugin, macOS)
noatikl_VSTi_win.dll (Audio Plugin, Windows)

How to use Noatikl VSTi / AU with Reaper

Reaper is very easy to use with the Noatikl VSTi or Noatikl Audio Unit!

Follow these instructions to get something playing in under two minutes!

1. Run Reaper.
2. New Project (it'll have started with a new project anyways).
3. Track -> Insert New Track.
4. Click the "FX" button in the silvery panel on the LHS side; that panel is basically the controller for the

track, the FX is how you attach FX chains (VST/AU) to the track...
5. Type noatikl in the filter list to make it easy to find...select either the AU or VSTi version of Noatikl, and

press OK.
6. In Noatikl, File -> New -> Simple (or open a file you already have).
7. In Reaper, press the play button

Logic / Logic Express / GarageBand for Mac

Logic and Garage Band both support Audio Units
You can also use Noatikl standalone with Logic
Relevant Noatikl versions:

noatikl.app (Desktop Standalone, macOS)
noatikl_AU_mac.component (Audio Plugin, macOS)

How to use Noatikl AU with Logic / Garageband

To use Noatikl AU with Logic is very easy; simply download the template project zip and follow the video
tutorial.

Cakewalk (e.g. Sonar, HomeStudio) for Windows:

There are some keyboard issues with Sonar 6...
Relevant Noatikl versions:

noatikl.exe (Desktop Standalone, Windows)
noatikl_VSTi_win.dll (Audio Plugin, Windows)

How to use Noatikl VSTi with Sonar

Sonar works well with the Noatikl VSTi (albeit with some possible keyboard issues in older versions of Sonar)!
There can also be some timing problems inherent in using the Noatikl VSTi with Sonar; see here for more

https://intermorphic.com/noatikl/#faq-sonartiming
https://intermorphic.com/noatikl/#faq-sonar6keyboard
https://intermorphic.com/noatikl/index.html#logic_au
https://intermorphic.com/images/app/noatikl/3/resources/noatikl_au_template_logic_8.zip
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details about how to work-around these issues.

The steps for using Noatikl VSTi under Sonar Home Studio (which is similar to Sonar Studio/Producer) are as
follows (see also the video tutorial). These steps might also work (in slightly different form) with earlier versions
of Sonar; let us know if you find out.

Configuring the Noatikl VSTi the first time, for use with Sonar

When you've first copied the Noatikl VSTi to your computer, be sure to scan for the VSTi. On my machine, this
involves the following steps:

Select Tools -> Cakewalk Plug-in Manager from the Menu
In the VST Configuration section, click on the Options button. Add to the list of scan paths, the folder to
which you copied the noatikl_VSTi_win.dll file (on my machine, this is C:\Program
Files\Steinberg\Cubase SE 3\Vstplugins, but could also be something like C:\Program Files\Vstplugins) .
Press the Scan VST Plug-ins button.
Noatikl VSTi_win should now appear in the VST Instruments (VSTi) Plug-in Category.

Using the Noatikl VSTI within your Sonar Project

Step 1: Add the Noatikl VSTi to your project
To add the Noatikl VSTi to your project, do not start by using the synth rack; it will crash Sonar.
Insert the Noatikl VSTi by right-clicking the FX bin of an audio track; select the Noatikl VSTi plug-
in.
Load-up a Noatikl file (or create a new one) within noatikl. That will give you something to hear in
a moment. Make sure you set the MIDI Channel parameter for each voice, so you can be sure
which software synth you want to direct it to.
Next, open-up the Synth Rack (Views -> Synth Rack)
Right-click on the far-right pane of the Noatikl VSTi, and click on "Enable MIDI Output". This lets
Sonar use the MIDI output data emitted from the VSTi by noatikl. If you forget this step, Noatikl will
remain silent.
Close the Synth Rack.

Step 2: Add some Software Synths
Add as many software synths as you want to your Sonar Project; one for every distinct sound you
want rendered by your Noatikl piece. Each software synth is on a separate audio track, of course.

Step 3. Prepare your MIDI tracks.
Create one MIDI track per Noatikl MIDI channel that you're interested in. For every such track:

You must make sure that Input Echo is turned-on! Note: you can see weird behaviour with
Sonar, where changing one MIDI track's Input Echo status can reset the Input Echo status
of another track (!); watch-out for this. The way to avoid this is first to select the Options ->
Global -> General menu item, and ensure that the "Always Echo Current MIDI Track" item
is not checked (the default behaviour is that this is checked, which is not what you want).
Select the MIDI Input as the appropriate Noatikl MIDI output (for example, noatikl_VSTi_in
1-> MIDI Ch.1). Set a separate Noatikl MIDI output channel for each MIDI track.
Set the output device as the appropriate software synth that you added earlier.

We have found that if you should set-up at least some MIDI data in at least one track (such as
dummy MIDI controller events), otherwise the Noatikl data will be ignored! You probably also want
to set a loop start and end point (presumably, choosing a loop size equal to or greater than your
Noatikl Piece Length).
Save your project before you forget

Step 4: play and enjoy
Start playback - enjoy what you hear! Note that of course if you have too many software synths in

https://intermorphic.com/noatikl/index.html#sonar_vsti
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your project, or are running on a slow computer, you might hear some audio break-up.

Cubase for Mac and Windows:

See the tutorials for hints on how to get started.
Relevant Noatikl versions:

noatikl.app (Desktop Standalone, macOS)
noatikl.exe (Desktop Standalone, Windows)
noatikl_VSTi_win.dll (Audio Plugin, Windows)

How to use Noatikl VSTi with Cubase

Cubase Windows works well with the Noatikl VSTi. The steps for using it with Cubase are as follows (see also
the video tutorial). These steps might also work (in slightly different form) with other Steinberg authoring tools;
let us know if you find out.

Configuring the Noatikl VSTi the first time, for use with Cubase

When you've first copied the Noatikl VSTi to your computer, be sure to scan for the VSTi.

Using the Noatikl VSTI within your Cubase project

Step 1: Add the Noatikl VSTi to your project
To add the Noatikl VSTi to your project, launch the VST Instruments window by selecting Devices
-> VST Instruments from the menu
Insert the Noatikl VSTi by clicking the top area in the first VST instrument slot; select the Noatikl
VSTi plug-in (noatikl_VSTi_win or noatikl_VSTi_mac).
Load-up a Noatikl file (or create a new one) within noatikl. That will give you something to hear in
a moment. Make sure you set the MIDI Channel parameter for each voice, so you can be sure
which software synth you want to direct it to.

Step 2: Add some Software Synths
Return to the VST Instruments window.
Add as many software synths as you want to your Project; one for every distinct sound you want
rendered by your Noatikl piece. In the above screen shot, you'll see three soft synths that have
been set-up in the VST Instruments window, listed after the Noatikl VSTi plug-in.

Step 3. Prepare your MIDI tracks.
Create one MIDI track per Noatikl MIDI channel that you're interested in. For every such track:

Select the MIDI Input ("in") as the appropriate Noatikl MIDI output (for example,
noatikl_VSTi_win or noatikl_VSTi_mac ).
To ensure that your MIDI track listens-out to only one of the MIDI channels output by
Noatikl, select the Input Transformer button, and select the Local entry in the pop-up list
that appears. In the presets drop box, select Channel Filtering followed by the specific
channel that you want to listen to. Finally, set the Active Module 1 checkbox, and close the
window. In case you find these instructions confusing, you should find that they are made
clear in the video tutorial.
Set the MIDI Output ("out") to be the appropriate software synth that you added earlier.
You must make sure that Record Enable is turned-o.

Save your project before you forget
Step 4: play and enjoy

Start playback - enjoy what you hear. Note that of course if you have too many software synths in

https://intermorphic.com/noatikl/index.html#cubase_vsti
https://intermorphic.com/noatikl/index.html#cubase_vsti
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your project, or are running on a slow computer, you might hear some audio break-up.

Ableton Live for Mac and Windows:

Ableton Live does not supports pass-through of MIDI events generated from VSTis
Relevant Noatikl versions:

noatikl.app (Desktop Standalone, macOS)
noatikl.exe (Desktop Standalone, Windows)
noatikl_AU_mac.component (Audio Plugin, macOS)
noatikl_VSTi_win.dll (Audio Plugin, Windows)

How to use Noatikl VSTi with Ableton

The steps for using Noatikl VSTi under Ableton Live are as follows; these steps apply to both the Windows and
Mac versions of Ableton Live.

Configuring the Noatikl VSTi the first time, for use with Ableton Live

When you've first copied the Noatikl VSTi to your computer, be sure to scan for the VSTi from Ableton. Once
done, you should see noatikl_VSTi_win (Windows) or noatikl_VSTi_mac (Mac) in Ableton's list of "Plug-In
Devices".

Using the Noatikl VSTI within your Ableton Live Project

Step 1: Add the Noatikl VSTi to your project
Add the Noatikl VSTi by selecting the plug-ins view, and dragging noatikl_VSTi_win (Windows) or
noatikl_VSTi_mac (Mac) from Ableton's list of "Plug-In Devices" on to a MIDI track.
Show the input/output options for your tracks; set the track with Noatikl on it, such that input is set
to "No Input".
Show the Noatikl editor window, and set-up a file to play (e.g. create a couple of voices).
Set the Noatikl MIDI Output to be a spare MIDI port; such as MIDI Yoke NT 1 (Windows) or IAC
Port 1 (Mac); you can then hide Noatikl if you want to clear some screen space.

Step 2: Add some Software Synths
Create another MIDI track.
Drag a VSTi synth onto that track.
Make that track's MIDI Input to be the MIDI Port to which Noatikl is sending its data; such as MIDI
Yoke NT 1 (Windows) or IAC Port 1 (Mac) in this example.

Step 3: play and enjoy
Start it all playing
If you can't hear anything, make sure that the green "on" button was set in the bottom panel in
Ableton where Noatikl is shown. If this isn't enabled, you won't see Noatikl flash away when
playing notes; so that is a clue to if you need to press this button or not!

Pro Tools

We are not creating an RTAS plugin at this time, so recommend using Noatikl standalone with Pro Tools.
Relevant Noatikl versions:

noatikl.app (standalone macOS)
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 Logic [DT

There is a separate section just for Logic and Noatikl Standalone. This because to run Noatikl under the direct
control of Logic's own transport controls, and also route MIDI event data from Noatikl such that Logic can pick-up
that data, requires that a little bit of preparation work is done first.

Logic sums all incoming midi data to the current active track in the arrange window because this is normally what
you might want. However, it isn't what you want with Noatikl and the Logic manual isn't clear as to how to change
this.

Using Noatikl Desktop Standalone application with Logic Pro:

1. Enable IAC bus and assign this as the Noatikl output
2. Launch Logic
3. Select first track in the Arrange window and create an Audio Instrument track.
4. Insert instrument plug-in of choice.
5. Set MIDI channel of this instrument to 1
6. Arm for recording
7. Repeat for up to fifteen other tracks - assigning each one to a different MIDI channel
8. Go to File -> Song Settings -> Recordings
9. Check the box marked "Auto demix by channel if multitrack recording"

This now works correctly i.e. setting Noatikl to transmit on c1 directs the data to the first instrument in Logic,
transmitting on c2 goes to the second etc.

You are now ready to make amazing music with Noatikl and Logic on your Mac.

Noatikl, Logic and MIDI feedback

Noatikl V1.5+ listens to incoming MIDI data to allow you to create dynamic hyperinstruments.

In order to use this feature in the standalone version of Noatikl, Logic users need to take certain steps to eliminate
the risk of MIDI feedback.

Due to the way Logic implements it's own MIDI through system, it is essential for Noatikl to use different MIDI ports
for MIDI in and MIDI out. Port sharing will cause MIDI feedback, lockups and the risk of system crashes.

Instructions for using the IAC driver.

Open Audio/MIDI setup in the Applications/Utilities folder. Select the MIDI tab.

Double click on the IAC icon and select Ports Click on the Add port button underneath the ports window. Accept the
default setting by clicking Apply.

In Noatikl select IAC bus 1 as the MIDI output bus and IAC bus 2 as the MIDI input bus

Launch Logic.

Open the Environment window (Command 8) and select the Clicks and Ports layer.

Click on New -> Monitor to create a new Monitor object. Draw a cable from the Midi input object from IAC Bus 2 and
connect it to this monitor. Do not connect the output of this monitor to any other object in the environment.

In the arrange page, select "Settings -> Synchronisation". Click on the MIDI tab. Set the MIDI clock destination tab
to be IAC Bus 2 and you are good to go.

Instructions for MidiPipe

See also: Noatikl video tutorial - "creating your first piece on Mac" which will get you going with MidiPipe by

http://www.subtlesoft.square7.net/MidiPipe.html
https://intermorphic.com/noatikl/index.html#standalone_firstpiece_mac
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SubtleSoft in 1 minute.

To create a second MidiPipe port, drag another MIDI in and MIDI out into your current pipe.

Select the second MIDI input and click on the blue menu display tab to show all the MIDI inputs. Click on Edit virtual
Inputs

Click on New Virtual Input to add the second input, repeat this in the Virtual Outputs view to create a new virtual
output. Click Done.

Highlight the first Midi output in the pipe. Ensure the box marked Pass Through is unchecked (this box is checked
by default).

Save your Pipe.

In Noatikl select MidiPipe input 1 as the output and MidiPipe Output 2 as the input.

Instructions for Logic

Launch Logic.

Open the Environment window (Command 8) and select the Clicks and Ports layer.

Click on New -> Monitor to create a new Monitor object. Draw a cable from the MIDI input object from MidiPipe
Output 2 and connect it to this monitor. Do not connect the output of this monitor to any other object in the
environment.

In the arrange page, select Settings -> Synchronisation. Click on the MIDI tab. Set the midi clock destination tab to
be MidiPipe Input 2

 Noatikl Mobile [MO]

Noatikl Mobile  for iOS (available at the Apple App
Store) has all the power of Noatikl Desktop (including
support for PSE Soundfont (SF2) Wavetables) except
that it does not support Scripting, Listening Voices or
MIDI transport controls.

That said, it has a useful "Blend" mode for X-Y blending
of elements with a "drift" facility as well as support for
Inter-App Audio / Audiobus and CoreMIDI / Virtual MIDI.
As with Noatikl Desktop, Noatikl Mobile takes a bit of time
to master - but it is worth the effort.

This Noatikl Mobile section goes though the main areas
of the mobile interface so that you can become familiar
with what does what and we will go on from there. The
parameters are all detailed in the preceding Noatikl
desktop sections.

The "Views"

There are four main "Views" selectable via the bottom tab
bar (see Views below). The first two views are where you
design and blend pieces and are unsurprisingly called
the Design and Blend views. The other two views are the

Voices and Piece views, but more on those later. OK, let's get started, and to do that, we load Noatikl and from the

Noatikl 3 Mobile Load screen

https://intermorphic.com/pse/3/index.html#tg-wavetable
http://itunes.apple.com/app/id633262318
http://www.subtlesoft.square7.net/MidiPipe.html
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Files screen open and play one of the included demo pieces!

 Files [MO]

The Files screen is where you can create a new noatikl file, open one you have previously saved or
delete/duplicate files.

Note: If you are using both Noatikl 3.1+ for macOS and Noatikl 3.1+ for iOS then you may also want to use iCloud
rather than local storage (i.e. saving your files to your iOS device). If you use iCloud your files will also appear in
your Mac's iCloud Drive folder, meaning you can easily sync your Noatikl files between macOS and iOS devices
that share the same iCloud account. See the iCloud FAQ.

Top Panel

New: Select New to create a new file.

Action:

iCloud Sync: Select this to resynch your iCloud files.
Sort by Name / Sort by Date: This toggleable setting
allows you to sort your files by Name or Date.
Rename: Select to display a pop up dialog to rename the
file
Import from Clipboard: This option is displayed when you
have a Noatikl file on the clipboard.

Settings: Select for Settings used in Noatikl, including a
link to Info.

Edit:

Duplicate: Select the jiggling file(s) and then press the
Duplicate icon to create copies of the file(s).
Delete: Select the jiggling file(s) and then press the
Delete icon to delete the file(s).

Files Area

New: Select "Create New" to create a new file.

Saved File: Tap on one of the Saved File document thumbnails to open a previously created file. The thumbnail is
a representation of the generator network in your piece. A file's thumbnail will briefly jiggle when you close the file
and return to the Files screen, making it easy to see what file you have just played or edited.

File Name: Tap on the File Name for a pop up dialog to rename the file.

 Templates [MO]

The Templates screen is where you select and open templates that you want to base a new piece on (when
accessed via Files screen) or add to the current piece (when accessed via Design/Blend views).

Top Panel

https://intermorphic.com/help/index.html#faq-icloud
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Top Panel

On the left of the top panel is a button that takes you
back to the screen you came from. Depending on how
you accessed this screen, on the right is shown one of
the following:

"New" button which, if pressed will use the selected
template or piece as the basis for a new piece
"Merge" button which merges the selected template or
piece into the currently open piece and takes you back to
the view you were last in (Design or Blend)
Both "Open" and "Merge" buttons - you will only see if
you have selected one of the "Saved Files" (shown top of
the left hand list). The "Open" button is just a quick route
to open an existing piece.

Template List

On the left is the Pak (a kind of grouping) and on the
right the template. Tap a template to preview it. Tap it
again to stop the preview.

Saved Files

Always shown at the top for easy accesss, this is list of pieces you have already created and saved.

Standard (Empty) Templates

There are two simple templates that you can choose as plain starters.

Noatikl Seed (Voicetype) Templates

These let you start a new piece with a particular voice type.

Tiklpak Templates

Noatikl Mobile includes all the templates that are in Noatikl, grouped by Tiklpak. There are a lot of templates, so just
scroll down the screen as you would any list in iOS.

 Design [MO]

The Design view is where you will do your piece construction and set up.

Top Panel

The top panel contains the "Files" button on the left and
the "Action" button on the right which is used to export
the Noatikl file to clipboard (e.g. for use in Wotja) or to
send it as an Email attachment.

Files Button

If you press this button you will see the Files Button
Popup with the following options:

Save & Close
Saves your changes, closes the file and takes you back

Templates Screen

https://intermorphic.com/wotja/index.html
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to the Files screen.

Save & Continue
Saves changes to the file and lets you continue editing
the file.

Save a Copy
Creates a new file (which you can rename) based on the
current state of the open file, but leaves you in the
current open file - meaning if you then exit the file you will
see this pop up dialog again letting you choose what to
do with the file. Note: This is NOT the same as Save As.

Discard
Lets you discard any changes you have made to the file since opening it.

Cancel
Closes the dialog.

Piece Status Panel

Below this is the small Piece status panel and this shows the piece name, elapsed time in Measures:Beats:Ticks
format (MBT), elapsed piece position (%) relative to the piece duration and the piece tempo.

Global FX Panel

The output from every FX is added together and passed through a PSE Global FX Network. If you want to use a
Global FX, click the "Glob FX" button to invoke the Global FX editor dialog. This dialog looks the same as for the
Track FX dialog.

By default, the dialog shows no FX units. You can alter the network to use a custom set of sound FX units in various
configurations; or select from a list of built-in preset FX.

Voice / Generator Network Editor

The central "Generator Network" editor / panel is where you marry voices (note generators) to MIDI channels, PSE
synth sounds and FX. It shows a view of all Noatikl NME Voices, together with cells showing the associated MIDI
channel and any PSE Synth, Track FX and Global FX settings.

Tap/hold on a voice and you can drag it up/down to change the voice order. If you drag from a Voice button to a
MIDI channel box that will tell the system that the Voice will play through the defined MIDI channel. If a new voice is
added to a piece, the voice won't be assigned to a specific MIDI channel; if you haven't yet hooked-up a Voice to a
MIDI channel, Noatikl will decide on a free MIDI channel to hook-up the Voice to when it starts playing.

MIDI Channel
The Voice "NME Patch" parameter (see Voices View) defines which MIDI Patch command to send for each
MIDI channel - in general, you should only hook-up multiple Voices to the same MIDI channel if they all share
the same Patch parameter.

MIDI Channel 10
MIDI Channel 10 is reserved for the Drum instrument. Every voice with a Drum Patch, should generally be
attached to MIDI Channel 10.

Sound Generator
If the "Partikl" toggle is checked in the Settings screen, then MIDI events are routed for each channel through
a PSE Synth configuration defined by the associated Synth box, which by default will use PSE's built-in MIDI
Wavetable synth (using the Patch defined by the Voice's Patch parameter). If you want to use a custom

Design View

https://intermorphic.com/nme/3/#voice_patch
https://intermorphic.com/nme/3/#voice-types
https://intermorphic.com/pse/3/index.html
https://intermorphic.com/nme/3/#generator-network
https://intermorphic.com/pse/3/index.html#networkeditor
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sound, click the Synth button to invoke the Synth editor dialog.

Track FX
The output from every Synth box can be passed through a custom FX Network. If you want to use an FX, click
the FX button to invoke the FX editor dialog.

Tap on a voice to get a standard iOS pop-up menu (Edit | Mute / Hear | Solo / All | Delete | Copy / Paste). To Paste
a voice (once copied) you must tap an existing voice and then select Paste.

Toolbar

The toolbar contains the Play/Stop control, as well as a button to add templates, buttons for mute and solo screens,
and a help/more button.

Views

At the bottom of the screen are 4 tabs that allow you to display the 4 main views, Design, Blend, Voices and Piece.

 Blend [MO]

The Blend view is where you will do your piece blending (easily change volume and pan settings) and also have fun
with the drifting capability (where voices can auto blend)!

Top Panel

The top panel contains the "Files" button on the left and
the "Drift" button on the right. The 4 Drift options are:
Manual (blend), Drift, Flock, Drift & Flock.

Piece Status Panel

As Design screen.

Central Area

The central area shows the piece voices and you drag
them left/right to change their pan position, or up down to
change their volume. Tap on a voice to get a pop-up
menu (Edit | Mute / Hear | Solo / All | Delete | Copy / Paste
| Pin). Selecting Pin will allow you to anchor that voice so
that it will not drift.

Toolbar

As Design view

Views

As Design view.

 Voices [MO]

The Voices view is where you edit all the parameter values for each of the voices in the piece. Simply select the
Parameter Group on the left hand side, and then edit the parameters on the right!

Top Panel

On the left of the top panel is a "Files" button and on the

Blend View

https://intermorphic.com/noatikl/guide/index.html#noatikl-mobile-piece
https://intermorphic.com/noatikl/guide/index.html#noatikl-mobile-voices
https://intermorphic.com/noatikl/guide/index.html#noatikl-mobile-blend
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right is Undo/Redo.

Voice # Selector

Tap left or right of this to quickly move between NME
Voices.

NME Voice Parameter Groups (left panel)

Tap one of the groups to display, on the left, the
parameters for that group. Refer to the NME Guide for
information on Voice parameters.

 Piece [MO]

The Piece view is where you edit all the NME Piece parameter values for the piece itself. Simply select the
Parameter Group on the left hand side, and then edit the parameters on the right. Refer to the NME Guide for
information on parameters.

Top Panel

On the left of the top panel is a "Files" button and on the
right is Undo/Redo.

NME Piece Parameter Groups (left panel)

Tap one of the groups to display, on the left, the
parameters for that group. Refer to the NME Guide for
information on Piece parameters.

Tips

The Piece parameters can make a big difference how
your piece sounds, especially the tempo and root. When
exporting a piece for use in Mixtikl, remember that it is
best to use a maximum piece length (32,000 seconds).

If you are going to be making your piece available for
others to use, you may well wish to include your own
copyright statement for the piece. Each voice can also
have its own copyright statement.

 Settings [MO]

Voices View

Piece View

https://intermorphic.com/nme/3/
https://intermorphic.com/nme/3/
https://intermorphic.com/nme/3/
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This screen is where you configure how you want Noatkl to play its sounds and how to control other apps via
Audiobus and Core MIDI.

Top Panel

On the left of the top panel is a button that takes you
back to where you have come from.

Information

The first item on this screen, the Information button takes
you to the Information screen which shows the version
number and has a number of useful links including to this
User Guide.

Audio Output

Note : Inter-App Audio and Audiobus are on by default.
To use either of these you need to route Noatikl via an
Inter-App Audio or AudioBus enabled app.

Partikl (PSE) Synth for Sounds & FX: On by default.
Enables PSE sounds, which all voices use as this is the
sound generator for Noatikl. Turn this to off when you
want to play through an external synth(s) and you do not
want to hear the PSE sounds as well.

NOTE: When this is set to OFF you will not hear anything
from Noatikl unless you have a MIDI device connected

(and you will hear sounds through that instead).

Audio Rate : 44 kHz by default. 44 kHz gives the highest quality sound output from the modular synth (should you
be using that). Depending on how complex your piece is in terms of sounds and FX, however, older devices might
struggle at this output rate. In which case, you can try reducing how hard Noatikl works the processor by reducing
the output rate to 22 kHz.

MIDI Input

Note: MIDI Input is only used by Listening Voices.

Tap the MIDI Input button to go to the MIDI Input Devices screen where you will see toggles for all MIDI Input
Devices detected by Noatikl.

Network Session:
This is used for detecting MIDI sent via a network (e.g. from a Mac over WiFi).

Noatikl + Channels:
These allow Noatikl to detect MIDI it sends out over Virtual MIDI (see below). As it is a kind of MIDI feedback it
is for specialist use and unlikely you will need to use it.

App / MIDI Device + Channels:
All 3rd party MIDI emitting Apps or MIDI devices Noatikl detects will be shown here; toggle on the ones you
want Noatikl to recieve MIDI input from.

Enable MIDI Input Toggle

Shown at the bottom of the screen, don't forget to turn this on (it is on by default) if you want Noatikl to detect
incoming MIDI!

Settings Screen

https://intermorphic.com/nme/3/#voice-type-listening
https://intermorphic.com/pse/3/index.html
http://audiob.us/
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MIDI Output

Core MIDI: Off by default. When enabled, tells Noatikl to send-out MIDI events via Core MIDI. Apps that are Core
MIDI enabled can take advantage of this.

Virtual MIDI: Off by default. When enabled, causes Noatikl to present a number of Virtual MIDI ports - one Omni
(all channels) and 16 per-channel virtual MIDI ports - and Noatikl sends MIDI events as Virtual MIDI ports over Core
MIDI.

MIDI Clock: Off by default. When enabled, tells Noatikl to send-out MIDI Clock events over Core MIDI / Omni
channel.

Important Note: The iOS version can emit MIDI clock but it doesn’t support MIDI transport controls.

Latency: 100ms by default. Sets Latency (milliseconds) to apply to MIDI events sent-out to Core MIDI / Virtual MIDI
by Noatikl. Use to help remove jitter if using e.g. Network MIDI.

Tuning: Off by default. Useful option for tuning external analog synths - causes all notes sent-out by Noatikl to be
"forced" to the specified pitch.

Miscellaneous

Show Noatikl 2 Content

This toggle allows you to hide the older Noatikl 2 templates, making it easier to see what is new for Noatikl 3.

 Rule Editor [MO]

This view is where you select and (real-time) edit the Rules used in your voice or piece - be they Scale, Harmony,
Next Note or Rhythm rules.

Rule Edit area

This control lets you change the rule elements. Tap on
the element to change its value. The composition engine
accomodates all rule changes in real-time - which can be
a lot of fun!

So that you can tell when a voice using the currently
selected rule composes using it, it flashes the colour of
the voice type used by that voice. This is primarily to
remind you that other voices rely on that rule, so if you
are going to change it then the way other voices
compose may change, too. It can be useful to have the
same rule used by all voices, but if you want to, then
each voice can have its own rule!

Rule List

Below the Rule Edit area is a scrollable list contains all of
the defined rules. Tap a rule to select it so that you can
edit it in the Rule Edit area above.

Toolbar

The toolbar contains the Add Rule button, as well as a
the Edit Rule Name, Cut, Copy and Paste buttons and the Delete button. When you select the Add Rule button you

Rule Editor View

http://www.iosmusician.com/app-lists/core-midi
http://developer.apple.com/library/ios/#documentation/MusicAudio/Reference/CACoreMIDIRef/
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are presented with a set of included default rules. For Scale rules these include Major, Minor, Dorian, Hypodorian,
Hypolydian, Hypomixolydian, Hypophyrgian, Lydian, Mixolydian, Pentatonic, Phrygian.

 Pattern Editor [MO]

This view is where you edit all the Pattern parameters. Patterns are a little tricky to use in the mobile version
(because of limited string editing), so be aware.

Edit Pattern

Tap in the field to edit the NME Pattern or Sub-pattern.
The NME Pattern Syntax can take a bit of getting used to
and you will need to study it carefully if you want to use
patterns.

Toolbar

The toolbar contains the Add Pattern button, as well as a
the Up and Down buttons to move patterns up and down,
the Delete pattern button and the Presets button. Select
the Presets button display a list of preset included
patterns to choose from.

IMPORTANT: The pattern you select in the presets list
OVERWRITES your current selected pattern.

Tip

Patterns are a way that can be used to create hidden
structure in a piece. Set up a voice to be of Voice Type
Pattern, set its volume to be zero (e.g. in the Blend view),
but do not mute it (or it will not count in terms of
composition). Then, follow that Fixed Pattern voice with

another voice. Set up the following voice with Chords Strategy set to Chordal Harmony and you will never hear the
pattern but it will be used as an invisible skeleton around which to compose! If you want to hear the pattern, set
Follows Strategy to Semitone Shift.

 FAQ

General FAQ

Common

What are the key feature differences between Desktop and Mobile versions?

Noatikl Mobile has access to all of the parameters that are in Noatikl Desktop and includes the same
templates/content. Content authored in either will play just fine in the other, and vice versa. There are not
many feature differences between the two, but the Interfaces are of course different (see below). A good point
of reference is the Noatikl User Guide.

Features

In terms of features, Noatikl Mobile can do everything Noatikl Desktop can do except:

Patterns View

https://intermorphic.com/noatikl/guide/index.html
https://intermorphic.com/noatikl/#OSX
https://intermorphic.com/noatikl/#iOS
https://intermorphic.com/noatikl/#faq
https://intermorphic.com/nme/3/#voice-type-fixedpattern
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Noatikl Mobile does not support Scripting.
Noatikl Mobile does not have a plugin version (i.e. no Audio Unit for mobile).
Noatikl Mobile can emit MIDI clock information but it doesn’t support MIDI transport controls.
Noatikl Mobile does not allow MIDI file recordings to be made (you would need to use another iOS app
for that).

Noatikl Mobile has a number of small additional advantages over Noatikl Desktop:

Noatikl Mobile has a Blend view that provides an easy way to drag voices around to mix them (and this
is very handy).
Noatikl Mobile has a Settings screen that lets your set the Audio output rate and supports a number of
MIDI Output options.

Interfaces (UI)

Beyond a pure feature comparison, many people find that desktop versions of apps allow greater productivity.
There are too many differences to detail here but the Noatikl User Guide documents both the Noatikl Mobile UI
and Noatikl Desktop UI.

Suffice to say, if you are planning on doing a lot of deep editing or composition then you might find it easier
and quicker, therefore, to do things in Noatikl Desktop which has a multi-voice table view of parameters and
requires much less drill down - a mouse is very very handy. Some UI areas are also just easier to use in the
Desktop version, for example text editing / use of Patterns.

It's your choice...

All said and done, Noatikl Desktop costs more so maybe you start with the Mobile version and then see how
you get on!

How do I export, backup or restore my Noatikl Files?

To SAVE or EXPORT pieces/files you can either:

Export them as email attachments
See: Noatikl iOS Pieces screen or Noatikl Desktop File Menu.

Use iTunes File Sharing
See: Copy In/Out.

To RESTORE pieces/files:

Use iTunes File Sharing
See: iOS < > Mac / PC and also http://support.apple.com/kb/HT1766.

How do I copy/transfer Noatikl pieces into Mixtikl?

See here.

How do I copy/transfer SF2 files into Noatikl?

See here.

https://intermorphic.com/mixtikl/guide/#copyinout
http://support.apple.com/kb/HT1766
https://intermorphic.com/nme/3/#patterns
https://intermorphic.com/noatikl/guide/index.html#noatikl-desktop
https://intermorphic.com/noatikl/guide/index.html#noatikl-mobile
https://intermorphic.com/noatikl/guide/index.html
https://intermorphic.com/noatikl/guide/index.html#noatikl-mobile-settings
https://intermorphic.com/noatikl/guide/index.html#noatikl-mobile-blend
https://intermorphic.com/nme/3/#scripting
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I hear silence, help!

PSE

If Noatikl isn't making any sound, first check that you have the Partikl checkbox ticked. If this is ticked, then
Noatikl will automatically render all MIDI data that it generates through Noatikl's built-in Partikl sound system,
and you should hear Noatikl playing (unless you've turned-down your computer's volume). If the checkbox isn't
ticked, Noatikl will only send its MIDI data to whatever MIDI Output destination you have defined in Noatikl's top
panel... which means that you've probably got a bit of MIDI configuration to do first in order to hear Noatikl
play.

Note that Noatikl can play both through PSE and through a MIDI device, if that is how you have configured
things - the choice is yours.

All platforms:

Don't forget to press play! Make sure your system volume is turned-up, and any speakers are turned on!
Make sure you haven't muted all voices, or set their volumes or velocities all to zero. If you are using fixed-
pattern voices, make sure they don't all have empty patterns.

iOS:

Unless you are using AudioBus, make sure this toggle (under Settings > Audio Out) is set to off or
you will not hear anything!

Windows users:

Only one component at a time can render through the Windows Software Synth. If your Noatikl MIDI Output
component is specified to render through this and you hear silence, make sure there is not already something
else trying to render through it.

MAC users:

If you selected an IAC driver bus as Noatikl's MIDI output device, make sure you have an active rendered out
for that device e.g. MIDIPipe from Subtlesoft or one of your sequencer tracks with an attached synthesiser or
sampler plug-in. Please refer to the Noatikl video tutorial - "creating your first piece on Mac" which will get you
going with MidiPipe in about 1 minute.

Sonar

You may hear silence when using Noatikl MIDI events with the Noatikl VSTi with Sonar.

The solution to this problem is to modify your MIDI track to have a continuous stream of dummy MIDI
controller events! This is required for Sonar to keep “pumping” Noatikl for more MIDI event data.

If using the Noatikl VSTi and your hear silence, make sure you have added Noatikl VSTi to your project
properly.

To add the Noatikl VSTi to your project, do not start by using the synth rack; it will crash Sonar.
Insert the Noatikl VSTi by right-clicking the FX bin of an audio track; select the Noatikl VSTi plug-in.

https://intermorphic.com/noatikl/index.html#standalone_firstpiece_mac
http://www.apple.com/downloads/macosx/audio/midipipe.html
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Load-up a Noatikl file (or create a new one) within noatikl. That will give you something to hear in a
moment. Make sure you set the MIDI Channel parameter for each voice, so you can be sure which
software synth you want to direct it to.
Next, open-up the Synth Rack (Views > Synth Rack).
Right-click on the far-right pane of the Noatikl VSTi, and click on "Enable MIDI Output". This lets Sonar
use the MIDI output data emitted from the VSTi by Noatikl. If you forget this step, Noatikl will remain
silent.
Close the Synth Rack.

Cubase

If Noatikl VSTi MIDI events create silence, make sure you are not running with the “Sequencer MIDI Pipeline”
selected. Not all sequencers support this feature.

The solution is to select one of the other MIDI output ports instead (and make sure you have a
synthesiser listening out for that port!).

Crash Logs, where do I find them?

See: Where do I find Crash Logs? and send the text in them through via our Contact Form, and don't forget to
tell us what you were doing when you had the crash! Hopefully we will be able to fix the crash in the next
update. Thank you!

Background

We try as hard as we can to make our apps stable. If this app does crash on you, then the chances are that
for crashes in new apps (released after Jun 2014) we will (but not always) get reports from the HockeyApp
integrated crash reporting system. Because of this, we have the best chance of fixing crashers and so our
latest versions are likely to be the most stable. This is one reason we recommend that you always update your
Intermorphic apps to the latest version, where your device/OS allows.

If you are using an earlier app then you can still send us a crash log so that we can investigate and try to fix
the problem (for all users). The crash log files all start with the app name, and have an extension "crash".
They are text files that we can read, and give us useful information in tracking-down a crash.

Even though we get the crash logs, it can also help us track things down if you send us any info about your
particular crash, or indeed anything you think is not working right.

How do I get Mixtikl parts into Noatikl?

When using Mixtikl (mobile or desktop), you can export the content in individual cells where that content is
generative (i.e. not audio loops), and then import it (as a new piece or added to an existing piece) for editing
in Noatikl (mobile or desktop). There is one exception, and that is where the Mixtikl content uses a custom
wavetable. In this case you will need to import it to a new piece and not merge into an existing one.

For Mixtikl Mobile > Noatikl Mobile

In Mixtikl, select the Content Cell you are interested in.
From the Content Cell menu select the Export button and you will get a message saying that the data
has been exported to the clipboard.
In Noatikl Mobile, go to the Pieces screen and then select the import button on the bottom toolbar. You

https://intermorphic.com/noatikl/guide/index.html#screen-pieces
https://intermorphic.com/help/#contact
https://intermorphic.com/help/index.html#faq-crashlogs
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will get a pop up dialog givng you the option to add the content to the existing piece, or to replace it.
Choose the option you want and the content is imported and ready for editing. Once you have done
your editing, you can of course export the piece and then import into a Mixtikl content cell.

Note: When you export from a Mixtikl content cell the Track FX are NOT included (but Cell FX are).

Note: Doing this in Mixtikl Desktop > Noatikl Desktop is similar except that in Noatikl the "Import" facility is under
Menu > File > Import.

How do I export Noatikl pieces and then import into Mixtikl?

For Noatikl Mobile > Mixtikl Mobile:

In Noatikl, go to the Pieces screen and then select the export button on the bottom toolbar. get a
messages saying the data has been exported to the clipboard.
In Mixtikl, select the content cell you are interested in.
Select the Import button and you will get a popup dialog where you choose what kind of clipboard to try
to import from. Select the Noatikl/Partikl button.
You will be presented with an "Import As" dialog where you enter the name you want the content called
(or just accept the default name presented).
You will see a couple of pop-up messages saying the content imported.

Note: Doing this in Noatikl Desktop > Mixtikl Desktop is similar except that in Noatikl the "Export" facility is under
Menu > File > Export.

How do I install Noatikl?

See the installing Noatikl page for how to install the various Noatikl variants on your system!

How do I re-install an older version of Noatikl Desktop Audio Plugin for Mac?

If you have deleted e.g. Noatikl 2.1.5 Desktop Audio Plugins from your Mac and installed the Noatikl 2.3.3.
Plugins (which require macOS 10.7+) and then try to re-install the Noatikl 2.1.5 Plugins (as you have sensibly
made a backup) then you may find you get the message "Intermorphic Noatikl can't be installed on this disk. A
newer version of this software already exists on the disk."

Ultimately it is down to Apple's decision not to expose uninstall options in the menu somewhere!

Solution:

Close any installer you might have open
Open the Terminal application (under Applications -> Utilities -> Terminal)
Paste these 4 lines into the Terminal window:

sudo rm /var/db/receipts/com.intermorphic.noatikl.plist /var/db/receipts/c
om.intermorphic.noatikl.bom

sudo rm /var/db/receipts/com.intermorphic.noatikl.plist /var/db/receipts/c
om.intermorphic.noatikl.plist
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sudo rm /var/db/receipts/com.intermorphic.noatikl.plist /var/db/receipts/c
om.intermorphic.noatikl_plugins.bom

sudo rm /var/db/receipts/com.intermorphic.mixtikl.plist /var/db/receipts/c
om.intermorphic.mixtikl_plugins.plist

You can then install your older copy of Noatikl!

Note: the first time you enter the "sudo" command-line, you'll be prompted to enter your password.

Explanation: the "sudo" command tells the system to run the command that follows with an administrative level;
otherwise, you wouldn't be able to remove the (hidden) receipt files that are blocking your re-installation of the
older version.

I've downloaded the software, but when trying to install I get an error message

In this sort of case, it almost certainly means that your Web Browser file cache is corrupted. You'll need to
refresh/clear this cache, and try the download again.

When I launch Noatikl on Mac either as standalone or as VST within a host and try to open a new file it quits
(and forces the host to quit also)?

This is the result of an oddity we've seen in some Macs. Please try the following simple steps.

Try this first
1. Go to "System Preferences"
2. Select "Displays"
3. Choose the "Color" Tab
4. Uncheck the "Show profile for this display only"
5. Select the "sRGB IEC61966-2.1" profile

If the above doesn't work, then please try this:
1. Select Options menu
2. Select "Reset Column Widths"

I want to get started quickly - where are the video tutorials?

See the video tutorials section for a lot of video tutorials on using Noatikl.

What Sequencers support interactive MIDI?

See the plug-in discussion in the Noatikl user guide.

How do I sync Noatikl Desktop Standalone to my DAW / Sequencer's MIDI clock?

As we test in Reaper, we give the following instruction for that (and then the Mac variant, too). But, the

https://intermorphic.com/noatikl/guide/index.html#plugin_variants
https://intermorphic.com/noatikl/#videos
https://intermorphic.com/noatikl/#downloads
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principle is the same for other DAWs / sequencers and concerns enabling MIDI Clock and Sync events to be
sent from your DAW / Sequencer to Noatikl and then enablng MIDI events to be sent from Noatikl back to your
DAW / Sequencer.

Important in all cases: You need to use a different bus for each of the above activites, e.g. IAC Driver - Bus
1 for MIDI input and IAC Driver - Bus 2 for MIDI output.

Note: We also refer to the Mac's inbuilt IAC Audio MIDI Setup - for more on that see here.

1. Reaper MIDI Output: from the Menu select Preferences > Audio > MIDI Devices and in the MIDI output
area double tap on the desired / listed MIDI output device (e.g. IAC Driver - Bus 2) and ensure that
"Enable output to this device" and "Send clock/SPP to this device" are both checked.

2. Reaper MIDI Input: from the Menu select Preferences > Audio > MIDI Devices and in the MIDI input area
double tap on the desired / listed MIDI input device (e.g. IAC Driver - Bus 1) and ensure that "Enable
input from this device" and "Enable input for control messages" are both checked.

3. Noatikl: Set "Sync?" set to True, set MIDI Input to be the same as your MIDI output above (e.g. IAC
Driver - Bus 2) and set MIDI Output to be the same as your MIDI input above (e.g. IAC Driver - Bus 1)

4. Noatikl: Press Play ... Noatikl is now waiting...
5. Reaper: Press Play ... Noatikl starts playing, at the tempo from Reaper.
6. Note: Noatikl does not currently support "Resume", so if you press "stop" in your Sequencer, then to

restart Noatikl you will first need to rewind your Sequencer head to the beginning before pressing "play".

Should I use the Desktop Standalone or Desktop Audio Plugin version?

See the suggestions in the Noatikl user guide.

Directing MIDI out

If you want Noatikl to drive a MIDI output device with MIDI data, you will first need to specify the MIDI output
device to which Noatikl sends its MIDI data.

If you are running within Cubase or other sequencers which do not support MIDI routing from one VST to
another then, you must, select any value other than "Sequencer MIDI Pipeline" (otherwise you will just hear
silence). If you are using Sonar, Reaper, or some other VSTi Host which allows MIDI data to be routed from
one VSTi into another one, then you may select any of the available options though you are most likely to
want to select the "Sequencer MIDI Pipeline" option.

Mac users using the Noatikl Audio Unit (AU) - you must route the output via an IAC port to a suitable synth
device.

See the MIDI Routing and the MIDI Output pages in the Noatikl User Guide.

See also the installing Noatikl page for how further information on how to configure the various Noatikl variants
on your system.

How do I record MIDI files?

There are two ways for Noatikl to record MIDI files. Note that there is one (Type 1) MIDI file saved per
'playback'; but each instrument is recorded to an individual MIDI 'track' within that file.

https://intermorphic.com/noatikl/guide/index.html#installation
https://intermorphic.com/noatikl/guide/index.html#midi-output-list
https://intermorphic.com/noatikl/guide/index.html#midirouting
https://intermorphic.com/noatikl/guide/index.html#which-variant-to-use
https://support.apple.com/kb/PH5172
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1. By recording a live take of the MIDI events that Noatikl is generating (see Noatikl Preferences).
2. By "Cooking" (see Tools > MIDI File Cooker), which is much faster, and plays / records the piece as fast

as it can - a 3 minute piece can take seconds to record this way.

How can I autocontrol the tempo in Logic?

Set up a pattern Voice in Noatikl on channel 1.

Set another Voice on channel 16. Set this Voice's Micro Controller 1 to send  CC22 with the mode set to 1-
LFO (min, max, min), beat frequency 2000.

Set Noatikl to sync to the IAC port for which you are generating MIDI clock from Logic.

Open the Logic environment. Cable a tempo fader between midi ports and  sequencer input - set it to listen for
CC22 on channel 16.

Set the piece tempo in Logic to <50 and hit play.

The Tempo of the ensuing Piece ranges between 50 and 172 BPM according to the cycle output of the
controller LFO in noatikl.

Sit back and feel clever.

Note that the choice of midi channels and CC22 is entirely arbitrary. You can use any channel or CC you want.
As long as the settings in Noatikl are matched to the settings in Logic, you are in business.

You can, of course, set up multiple "voices" in Noatikl simultaneously generating CC 22 on channel 16 to
different rules and specifications to create really strange and unpredictable tempo effects. There is a lot more
generative potential here than you can get from a simple tempo envelope.

Noatikl from Mac App Store crashes when I run it?

This issue is most likely due to Noatikl running in 64bit mode. We have yet to isolate the problem but we are
working on it!. This will most likely get you going:

1. Please find the Noatikl application in your Applications folder.
2. Right click on it, select the "Get Info" option.
3. Check the "Open in 32-bit mode" checkbox.
4. Re-start Noatikl.

I used to be able to export files as Music URLs for tweeting and sharing that way. How do I do it now?

As of Noatikl 3 export or playback of Music URLs is no longer supported. If you want to share your pieces you
have 2 choices. In Noatikl 3 either:

Share a piece (e.g mypiece.noatikl), e.g. via email; or
Export to clipboard the Noatikl piece and import this into Wotja. Then, share your wotja as a Wotja URL.

Can Noatikl import Koan files (SKD, SKM, SKT)?

https://intermorphic.com/wotja/guide/#action
https://intermorphic.com/wotja/guide/#content-wj
https://intermorphic.com/noatikl/guide/index.html#screen-pieces
https://intermorphic.com/noatikl/guide/index.html#preferences
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Yes, from Noatikl 2.1.3 it can. See importing Koan files.

Where do I find the older Noatikl 2 included templates?

By default we hide the older Noatikl 2 templates simply as the new Noatikl 3 templates are so good! They are
included, however, and it is easy to display them. Simply go to Settings (iOS), Noatikl > Preferences (macOS)
or Noatikl > Options > Preferences (Windows) and check the box that says "Show Noatikl 2 Content". Once
you have done that, the older templates will show up in the template list in a dark grey colour.

Where do I find the older Noatikl 2 included PSE TG Sound presets (.tg)?

These are not included in Noatikl 3 as we now have a new set of gorgeous sound presets and templates (you
can also export favourite presets from these, too). But we are making them available if you want them; see
below.

Tip: You see the TG Preset list from the Network Editor screen and when you then select the "Open" [Desktop]
or "Action" [Mobile] buttons. Once the file below is copied to the right place, you may need to restart the app
for the Presets to be displayed.

Noatikl Desktop version: Download a zip of the TG presets and place that in the Intermorphic Folder or zips
folder under that.

Noatikl iOS version: Download the file above and then refer to Apple's docs on iTunes Apps File Sharing to
see how to copy them to your iOS device.

I deleted the Noatikl 3 demo pieces. How can I get them back?

Noatikl Desktop version: These are installed to the "Intermorphic Folder". If you want to get them back again,
just download a zip of the demo pieces and unzip that in the Intermorphic Folder.

Noatikl iOS version: Either re-install Noatikl iOS (making sure you FIRST BACKUP any pieces you have made
that you want to keep) or download the above zip file to a PC and unzip that in the "Intermorphic Folder".
Then, refer to Apple's docs on iTunes Apps File Sharing to see how to copy them to your iOS device.

iOS

I have Noatikl 3 for iOS and am getting some performance issues (slow, stuttering, breakup) or audio artifacts
(glitches, crackles, pops etc). Why?

General comment: For Mixtikl 7 / Noatikl 3 the Partikl Sound Engine (PSE) Sound Units (Wavetable, Tone,
DSynth, Particle) now run in stereo. In Mixtikl 6 / Noatikl 2 and earlier these units ran in mono, even though the
PSE FX Units worked in stereo. Running the Sound Units in stereo does place a higher load on the processor,
however, it greatly improves the sounds that the PSE can generate so it was an essential change we had to
make.

You can get performance issues if the processor in your device is trying to do more that it can handle, and
there are a number of possible reasons for this when it comes to using Noatikl. You can also get some audio
artifacts occur in the PSE from "note stealing" (see below). However, before we look at any of those, there are

https://intermorphic.com/pse/3/index.html
https://support.apple.com/en-gb/HT201301
https://intermorphic.com/noatikl/guide/index.html#copyinout
https://intermorphic.com/noatikl/guide/index.html#copyinout
https://intermorphic.com/download/content/demos/NT3-demo-pieces.zip
https://intermorphic.com/noatikl/guide/index.html#copyinout
https://support.apple.com/en-gb/HT201301
https://intermorphic.com/noatikl/guide/index.html#copyinout
https://intermorphic.com/download/content/templates/IM_TG-NT2-MT6.zip
https://intermorphic.com/pse/3/index.html#networkeditor
https://intermorphic.com/sseyo/koan
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some general things to check / note first when it comes to conserving processor cycles so that the app can
use the maximum processor power available.

First:

Use latest iOS version: Ensure your device is using the latest iOS update available for it.
Power cycle your iOS device : This just ensures there is nothing running you don't expect to be
running.
Other running apps: Although mobile OS are good at managing app usage these days, it might well
be worth closing all other running apps.
InterApp Audio / Audiobus: Use of these takes up processing cycles, so try working without these on
(at least until you have found an approach that works for you).
AirPlay, WiFi, Bluetooth, Cellular data: Use of these takes up processing cycles, so try turning these
off. Why not try temporarily putting your devive into Airplane mode?
Don't run Noatikl backgrounded: There are less processor cycles available to the app when
backgrounded.
Cable connection to computer: If your device syncs, that, too, can use processor cycles, so try using
it without a computer connection (but charging it from a USB charging point is fine).

Try these (in order):

1. Audio Output Setting: The Noatikl 3 default audio output is 44Khz stereo, whereas Noatikl 2 defaulted
to 22Khz stereo. We changed it simply as the audio output sounds nicer at 44Khz stereo, and devices
have got more powerful in the last couple of years. However, runnning at 44Khz stereo places a higher
load on the processor. If you are having performance issues, this is the first thing to try changing.

Solution: Try setting Audio Output to 32Khz Stereo or even 22Khz Stereo. Noatikl Settings >
Audio Output.

2. Airplay: Airplay uses processing power to stream the audio, so if you are having performance issues
please first ensure this is off:.

Solution: Airplay = Off (see Apple docs).
3. Templates/Content: To make the new templates sound really great they take advantage of the stereo

sound unit capability (above) in the PSE. Some templates feature synth (and generator) networks are
really quite complex, too, meaning they will use more processor cycles. The processor useage therefore
greatly depends on the templates/content being used which means that some of the demo mixes will
take up more processor cycles than others. Also, how you configure the Partikl Newtork can also play a
part.

Solution 1 - Templates: Either use fewer templates in a piece so there is less sound to generate
(the cool Demo pieces use 3 merged templates but even that can be too much on some
devices!), use less complex sound generators (such as templates that have a sound network
primarily based on Wavetable units), or look to remove some FX units that are used in a template
(you can do this via the Synth Network Editor).
Solution 2 - Note Stealing: When the NME generates a lot of overlapping notes and Partikl is
generating the sound then unless the PSE Polyphony setting is sufficient to cover all the notes
that may be playing at the same time you can get an effect called "note stealing". This means a
newly composed note will play in preference to the a previously generated note, on a First in First
Out (FIFO) principle. The last note is instantly "dropped" meaning it can cause a click, especially
if you are using FX. See the Polyphony setting in the Synth Network Editor.

4. Track and Global FX: The new templates are generally sonically richer than Noatikl 2 templates and
most use a reverb and other FX in the template itself. If you have a lot of Voices in your piece, then a lot
of FX units can be in play at the same time.

Solution: If using these new templates in a (merged) piece, try removing FX from the templates

https://intermorphic.com/pse/3/index.html#networkeditor
https://intermorphic.com/pse/3/index.html#networkeditor
https://support.apple.com/en-gb/HT204289
https://intermorphic.com/noatikl/guide/index.html#settings
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themselves (e.g. reverb, as that is a heavy hitter), and then add it back as a Global FX. Example:
Copy one template's FX network to the the clipboard (FX Network Editor > bottom right Action
button > Export to clipboard) and then pasting it into the Global FX (FX Network Editor > bottom
right Action button > Import from clipboard) and then remove the FX from each Voice's FX
Network. This may change how the piece sounds quite a bit, so may require some
experimentation.

5. Merging pieces: Because of the Noatikl 3 template richness (above), you do not need many when
creating a piece.

Solution: Try merging no more than 3 templates. This should still give you PLENTY of goodness
to play with.

6. Use some older content, too: Because of the Noatikl 3 template richness (above), you do not need
many when creating a new piece. However, we still include the older Noatikl 2 content which in general
has less of a processing hit, so you might want to try sprinkling some of that in.

Solution: Noatikl Settings > Show Noatikl 2 Content.
7. Try to isolate the issue : If you have got this far down the list and are still getting issues, such as

ocasional clicks, glitches or pops etc., then it may be that the issue is coming from your piece and it
might be worth seeing it you can isolate the problem. That means gradually removing Noatikl voices and
PSE Sound Networks from your piece until the problem goes. Then you can work back up again.

Optional - MIDI Out: If you are STILL getting audio issues then it may well be worth trying to play
the NME MIDI note streams via external/3rd Party synths (using MIDI Out) and seeing if the issues
then go... If they do go, then it is likely the issue is something related to the PSE...

8. Your Device....: We put this at the very of this list because we know only too well that money does not
grow on trees and powerful mobile devices are very expensive. :( But, the device you are using is also a
factor to keep in mind. How our app sounds is very important and, to keep moving forwards, we have to
to take advantage of new capabilities and device power - we do this very carefully though.
Unfortunately, sound generation and sound processing is a heavy hitter, and, moving to stereo sound
units (see PSE comment, above) is just something we had to do...

Solution: If your funds allow, it might be worth at some point checking out a more powerful
device.

Crashers! Noatikl iOS is crashing after the latest update.

See: Where do I find Crash Logs? and send the text in them through via our Contact Form, and don't forget to
tell us what you were doing when you had the crash! Hopefully we will be able to fix the crash in the next
update. Thank you!

Background

We try as hard as we can to make our apps stable. If this app does crash on you, then the chances are that
for crashes in new apps (released after Jun 2014) we will get reports from the HockeyApp integrated crash
reporting system. Because of this, we have the best chance of fixing crashers and so our latest versions are
likely to be the most stable. This is one reason we recommend that you always update your Intermorphic apps
to the latest version, where your device/OS allows.

If you are using an earlier app then you can still send us a crash log so that we can investigate and try to fix
the problem (for all users). The crash log files all start with the app name, and have an extension "crash".
They are text files that we can read, and give us useful information in tracking-down a crash.

Even though we get the crash logs, it can also help us track things down if you send us any info about your
particular crash, or indeed anything you think is not working right.

https://intermorphic.com/help/index.html#contact
https://intermorphic.com/help/index.html#faq-crashlogs
https://intermorphic.com/noatikl/guide/index.html#settings
https://intermorphic.com/pse/3/index.html#networkeditor
https://intermorphic.com/pse/3/index.html#networkeditor
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Why is there no support for scripting in Noatikl Mobile?

Simply because Apple do not allow it. Scripting is required for Listening Voices to work, which is also why they
are not supported in Noatikl Mobile.

Note: If you open with Noatikl Mobile a piece contain scripting information (i.e. that you created in Noatikl
Desktop) then it just won't do anything. Althought it does not do anything in Noatikl Mobile, any scripting
information already in a piece is still included in the piece when it is saved.

Noatikl Mobile is slow and audio is breaking up, or it even crashes. What can I do?

Firstly, Noatikl should not crash, and if it does, please do submit us your crash logs.

For capabilities of your device (which may be an older model) your piece is too complex, or using too many
synth voices etc. In general the processing overhead is governed by the number of modular synth based parts
being used (and synth polyphony), the number of FX being used, the sheer number of parts playing etc. Here
are some things you can try:

If you are using Noatikl Mobile to control external MIDI synths and so do not need to use Noatikl's own
inbuilt synth for sound generation, then switch the Partikl switch to off. Same comment applies to
Audiobus.
If you are using Noatikl's synth, then try reducing the polyphony on the synth used for a voice, remove
some of the FX being used (Reverb is very expensive in terms of processor hit), or try even changing
the synth sound itself (patches that use the Particle generator are expensive in terms of processor hit)
If you need to use Noatikl's synth, then (coming in the next Noatikl update) set the audio output to
22KHz instead of 44KHz.

How do I use Audiobus / Inter-App Audio?

Audiobus / Inter-App Audio support is now enabled by default and can be used at no charge.

Please refer to the Apple website for information on how to use Inter-App Audio with GarageBand.

Please refer to the Audiobus website for instructions on how to use Audiobus. To use Audiobus you will also
beed to install the Audiobus app for iPhone, iPad and iPod touch. We make no charge to Audiobus suppport.

How can I use Noatikl for iOS recordings in iMovie for iOS?

See this forum topic.

Desktop

Why isn't my Product Key accepted / Product Key problems?

Note: If you have purchased a licence one of our tools via our website you will receive an email containing
your Customer ID, Order ID and Product Key. If you are having problems getting the Product Key accepted the

https://forum.intermorphic.com/viewtopic.php?f=24&t=2013
https://itunes.apple.com/app/audiobus/id558513570
http://audiob.us/
http://support.apple.com/kb/HT6038
https://intermorphic.com/noatikl/guide/index.html#screen-settings
https://intermorphic.com/pse/3/index.html#networkeditor
https://intermorphic.com/noatikl/guide/index.html#screen-settings
https://intermorphic.com/noatikl/#faq-crashlogs
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most likely reason is that either you have a space in front of or after the Product Key in the the
Product Key field (there should be no space) or, in Noatikl 2 you are trying to enter a Standalone
Product Key in the Plugin or vice-versa - see the note below.

Note for Noatikl 2 and earlier users: The Product Keys for the Desktop Standalone and Desktop Audio Plugin
versions were different and sold separately. To use the Standalone version requires the Standalone Product
Key and vice-versa.

From Noatikl 3 onwards the Standalone and Plugin Product Keys are the same. To continue to use the
Desktop Standalone version after the 30 day evaluation period requires that you purchase the Noatikl 3
Desktop Standalone licence from the Intermorphic webstore. The Desktop Audio Plugin is provided "As Is" and
is free to use once you have purchased the Noatikl 3 Desktop Standalone licence.

Check you have followed the Product Key section in the Noatikl User Guide.

Note: If you're running on Windows, and find Noatikl doesn't save its license key when you close the
application, use the Windows option to run the host software (e.g. Reaper 3) "as Administrator". Enter and
save your registration details. Restart the application normally: it should now be fine. If you've got trouble
saving the license key for the Desktop Audio Plugin, you should run the host application.

If the above does not get you going, then please try the following steps:

Close all instances of our software (including sequencers using our plugins).
Open the version of software for which you have purchased a license (e.g. Noatikl Desktop
Standalone or Desktop Audio Plugin variant - which means you first have to insert the Plugin into a track
in your DAW and then load the plugin from there), and from the Noatikl Menu select Help > Product Key
and enter your Customer ID, Order ID and Product Key. We recommend you copy and paste the
Product Key and do not try to type it in.
Once entered, close the software and restart it.
IMPORTANT: Ensure there are no spaces at the start or end of the Product Key.
Problems copying/pasting Product Key?

Mac - To paste on the Mac, you must:
Right-click in the text box, OR Control-click in the text box
... then select 'Paste' from the pop-up menu
Alternatively, click in the text box, and press Cmd-V / Applekey-V (the paste shortcut).
Ensure there are no spaces in front of or after the Product Key in the the Product Key field.

Windows - To paste on Windows, you must :
Right click in the text box
... then select 'Paste' from the pop-up menu
Alternatively, click in the text box, and press Control-V (for paste).
Ensure there are no spaces in front of or after the Product Key in the the Product Key field.

We have also had problems reported from Mac users with Microsoft Entourage. The issue is that
the Product Key is not being treated as plain text. Try this:

run TextEdit (you'll find TextEdit using Finder in the Applications folder)
copy the values from Entourage
paste the values into TextEdit (where it is set-up to be plain text, *not* RTF format!)
copy each value you need from TextEdit
paste into Noatikl...!
Ensure there are no spaces in front of or after the Product Key in the the Product Key field.

See also https://forum.intermorphic.com/viewtopic.php?t=263.
Tip: If you are still having problems, please contact us and let us know the version numbered displayed
in Help About (as well as OS version, how much free disk space you have, how much RAM do you have,

https://intermorphic.com/help/index.html#contact
https://forum.intermorphic.com/viewtopic.php?t=263
https://intermorphic.com/noatikl/index.html
https://intermorphic.com/store
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the format of your hard disk [e.g. FAT32]).

Where can find a virtual MIDI port for Windows (7/8/10)?

You might wish to try loopMIDI.

Note: We are not responsible for external links, 3rd party software etc.

How can I route external MIDI (e.g. Noatikl Desktop) to a DAW?

To see how to route external MIDI (e.g. generated by an app like Noatikl Desktop connected to e.g. loopMIDI
[Windows] or MIDIPipe [macOS] or Audio MIDI Setup (IAC Driver) [macOS]) to Reaper (a Desktop DAW which
may have Plugin Synths etc), hop over to the Cockos (Reaper) website and follow these instructions.

If you want to show the MIDI notes you've captured, have a look at this video.

Note: We are not responsible for external links, 3rd party software etc.

I cannot install your 64-bit software on Windows 10, why?

Our 64-bit Windows software will only install on 64-bit Windows; it will not install on a 32-bit operating system.
So it is most likely that you are not actually running 64-Windows.

To check which version of Windows 10 you are using, use the Windows search box to look for "About
Windows". This suggests "System Settings". Select that entry to go to the Settings screen.

At the bottom of the left hand panel in the Settings screen select "About". In the screen that displays you will
see something like "System Type: 64-bit Operating System, x64-based processor".

If you are running 32-bit Windows and want to run our software you will need to download in install the last-
released version of the related 32-bit software. These builds (where available) can be found in the relevant
Archive section of the app page: Liptikl 1.2.12 32-bit; Noatikl 2.8.8 32-bit, Mixtikl 6.3.8 32-bit. Not that they will
run in 30 day trial mode until you apply your Product License key.

I see on Mac you now only support 64 bit Noatikl, what if I need 32 bit Noatikl?

Apple’s tool chains no longer allow us to build 32 bit versions, and we’ve had to adapt with them.

You would be still able to use the archived 32-bit version which you could download/try out if you were
interested. The last ever release of that was Noatikl 2.1.5.

Plugin

Where is the VST Plugin installed? My DAW can't find it.

See: Installing Noatikl 3 Desktop Software Downloaded from IM Website

c:\Program Files\VstPlugIns

https://intermorphic.com/noatikl/guide/index.html#trial30day-win
https://intermorphic.com/noatikl/#archive
https://intermorphic.com/mixtikl/#archive
https://intermorphic.com/noatikl/#archive
https://intermorphic.com/liptikl/#archive
https://www.youtube.com/watch?v=Q0qd_cRE5dQ
http://wiki.cockos.com/wiki/index.php/Recording_MIDI
https://sites.google.com/site/mfalab/mac-stuff/how-to-use-the-iac-driver
http://www.subtlesoft.square7.net/MidiPipe.html
http://www.tobias-erichsen.de/software/loopmidi.html
http://www.tobias-erichsen.de/software/loopmidi.html


55/61

Important note: The Vst plugin is always installed to the \Program Files\VstPlugIns path shown above (and to
the drive Windows is installed to), irrespective of the editable folder destination shown in the installer, e.g.
“C:\Program Files\intermorphic\appname" where appname is the name of the Intermorphic app whose plugin
you are installing. The editable destination affects *only* where the plugin uninstall files are put (e.g.
unins000.dat and unins000.exe) so please leave it at the default setting.

Why isn't my Product Key accepted / Product Key problems?

Note: If you have purchased a licence one of our tools via our website you will receive an email containing
your Customer ID, Order ID and Product Key.

If you are having problems getting the Product Key accepted the most likely reasons are:

You are entering the license key into the wrong field; please sure you use the "Noatikl Product Key" -
don’t select "Noatikl Plug-in Extension key" (which is for something else altogether), or;
In Noatikl 2 you are trying to enter a Standalone Product Key in the Plugin or vice-versa - see the note
below, or;
You have a space in front of or after the Product Key in the the Product Key field (there should be no
space).

Note for Noatikl 2 and earlier users: The Product Keys for the Desktop Standalone and Desktop Audio Plugin
versions were different and sold separately. To use the Standalone version requires the Standalone Product
Key and vice-versa.

From Noatikl 3 onwards the Standalone and Plugin Product Keys are the same. To continue to use the
Desktop Standalone version after the 30 day evaluation period requires that you purchase the Noatikl 3
Desktop Standalone licence from the Intermorphic webstore. The Desktop Audio Plugin is provided "As Is" and
is free to use once you have purchased the Noatikl 3 Desktop Standalone licence.

Check you have followed the Product Key section in the Noatikl User Guide.

Note: If you're running on Windows, and find Noatikl doesn't save its license key when you close the
application, use the Windows option to run the host software (e.g. Reaper 3) "as Administrator". Enter and
save your registration details. Restart the application normally: it should now be fine. If you've got trouble
saving the license key for the Desktop Audio Plugin, you should run the host application.

If the above does not get you going, then please try the following steps:

Close all instances of our software (including sequencers using our plugins).
Open the version of software for which you have purchased a license (e.g. Noatikl Desktop
Standalone or Desktop Audio Plugin variant), select Help > Product Key and enter your Customer ID,
Order ID and Product Key. We recommend you copy and paste the Product Key and do not try to type it
in.
Once entered, close the software and restart it.
Tip: Do not have any spaces at the end of the Product Key ... or at the start.
Problems copying/pasting Product Key?

Mac - To paste on the Mac, you must:
Right-click in the text box, OR Control-click in the text box
... then select 'Paste' from the pop-up menu
Alternatively, click in the text box, and press Cmd-V / Applekey-V (the paste shortcut).
Ensure there are no spaces in front of or after the Product Key in the the Product Key field.

Windows - To paste on Windows, you must :

https://intermorphic.com/noatikl/index.html
https://intermorphic.com/store
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Right click in the text box
... then select 'Paste' from the pop-up menu
Alternatively, click in the text box, and press Control-V (for paste).
Ensure there are no spaces in front of or after the Product Key in the the Product Key field.

We have also had problems reported from Mac users with Microsoft Entourage. The issue is that
the Product Key is not being treated as plain text. Try this:

run TextEdit (you'll find TextEdit using Finder in the Applications folder)
copy the values from Entourage
paste the values into TextEdit (where it is set-up to be plain text, *not* RTF format!)
copy each value you need from TextEdit
paste into Noatikl...!
Ensure there are no spaces in front of or after the Product Key in the the Product Key field.

See also https://forum.intermorphic.com/viewtopic.php?t=263.
Tip: If you are still having problems, please contact us and let us know the version numbered displayed
in Help About (as well as OS version, how much free disk space you have, how much RAM do you have,
the format of your hard disk [e.g. FAT32]).

When I install Noatikl VSTi on Windows, why can't my host software find the plug-in?

Almost certainly, the issue is that you've not told your sequencer(s) to scan the appropriate folder for the
Noatikl VSTi. The folder in question is (depending on your system):

c:\Program Files\VSTPlugins (32-bit Noatikl VSTi: Windows XP, or 32-bit Windows 7/Vista)
c:\Program Files (x86)\VSTPlugins (32-bit Noatikl VSTi: Windows XP, or 32-bit Windows 7/Vista)
c:\Program Files\VSTPlugins (64-bit Noatikl VSTi: 64-bit Windows 7/Vista)

See also: Noatikl Installation

I've got keyboard problems with Noatikl VSTi under Sonar 6...

Sonar 6 currently (as of Sonar 6.2) has buggy handling of keyboard events for VSTis and the Noatikl plug-ins
are affected by this to some extent under Sonar 6.

The symptoms are that when using the Noatikl VSTi in Sonar 6.... various keys don't respond until you release
them; and then also appear in UPPER CASE rather than lower case. These keys include the following:
abcdefghiklmnopqstuvxz ...

We have logged this as a bug with Cakewalk. If it annoys you (and we're sure it will!), then do please feel free
to ask Cakewalk when they'll get around to fixing the problem.

We think the reason is that historically not many plug-ins have great support for keyboard handling. We've
worked hard to put great keyboard handling in Noatikl; and some operations such as naming Voices etc. of
course rely on typing on your keyboard.

Note that in Sonar 6, the VST host window includes a new button on the top right of its toolbar, which says on
the tooltip "Give all keystrokes to Plug-in". However, enabling this seems to make no difference at all to the
plug-in behaviour...

If you have problems where, for example, you want to name a Voice with lower case 'a' characters, but keeping
seeing 'A' instead, then consider using the standalone version of Noatikl to change the name before re-
opening in Noatikl VSTi under Sonar.

https://intermorphic.com/noatikl/guide/index.html#installation
https://intermorphic.com/help/index.html#contact
https://forum.intermorphic.com/viewtopic.php?t=263
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I've got timing problems with Noatikl VSTi under Sonar...

Sonar's VSTi host adaptor implementation has (historically) a pretty sloppy interpretation of MIDI event times
generated by VSTi plug-ins such as Noatikl. Current versions of Sonar may have addressed this, of course.

If you are experiencing this problem, consider sending MIDI data from Noatikl VSTi to Sonar via a MIDI Yoke
port, rather than sending them directly through the MIDI sequencer pipeline. Believe it or not, this gives far
better timing accuracy when you hear Noatikl's music render by your Sonar-hosted software synths.

Do you have a VST MIDI Effect for Cubase, or a DXi for Sonar/Cakewalk?

No: You should use the VSTi plug-in.

Why can't I attach the Noatikl AU to my Logic track?

You need to attach the Noatikl AU to an instrument track, and NOT an audio track. If you try adding to an
audio track, the Noatikl AU won't be listed!

Old

I have Noatikl 2 and text shows as lines in iOS 10...

Noatikl 2 was released for iOS 8 and Noatikl 3 was released for iOS 10. Each ran just fine on the iOS version
they were released for. It just so happened that Noatikl 2 also ran fine on iOS 9. It may only happen once in a
while, but changing the OS version of your device always has the potential to result in issues such as this.
Because developing and maintaining complex niche software like Noatikl is so hard and time consuming we
operate a Fullgrade model for upgrades - see our FAQ on this.

Background: It seems that what happened was that something in an underlying 3rd party library used in
Noatikl 2 meant that text does not display correctly once the device is updated to run iOS 10. At the point we
became aware of it we were already in the Noatikl 3 for iOS 10 product cycle and simply could not go back.

The solution was simple; Either A) see if you can downgrade your device back to iOS 9, maybe from a
TimeMachine backup; B) upgrade to Noatikl 3 for iOS 10 (it was ~$10 but that is no longer available) or C) as
Noatikl has now been superceded by Wotja which can load Noatikl files, purchase and use that instead.

We are really sorry if you got caught out my this, as we did, but again, this is why we operate a Fullgrade
model for upgrades - see our FAQ on this.

I have Noatikl 2, do I need to get Noatikl 3?

If you are happy with the features and interface of Noatikl 2, then you won't need Noatikl 3.

You would only need to get Noatikl 3 if you want to use any of the new features in Noatikl 3, play a mix made in
Noatikl 3 or to continue using Noatikl if your OS version will no longer run an earlier version.

Noatikl 3 for iOS, macOS and Windows is a new app so does not interfere with an installation of the no longer

https://intermorphic.com/noatikl/#whatsnew
https://intermorphic.com/store/#faq-upgrades
https://intermorphic.com/wotja
https://intermorphic.com/store/#faq-upgrades
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available Noatikl 2. It works with pieces you have made all previous versions of Noatikl.

How do I Restore an In App Purchase in Noatikl 2?

As of Noatikl 2.7.20 for iOS (a free update) Noatikl became a purchaseable full product with no IAP
Store. If you previously purchased an IAP and have 2.7.20+ you will find it fully unlocked with no
need for IAP!

Historical: Users of Noatikl 2.7.6 for iOS wishing to view the instructions for using the older Noatikl IAP store
and for restoring IAP purchases can find them in the archived Noatikl 2.7.6 PDF Guide.

How/where do I find content saved with Noatikl 2.3 (or earlier) Desktop (macOS/Windows)?

Files in Noatikl 2.3 and earlier were saved to the User_Content folder. You can find the User_Content
folder on your PC/Mac file system from the Noatikl Application menu. To use your own content in the app
simply copy it (including content zips) to this folder.

Noatikl 2.3 (or earlier) Desktop Standalone / Audio Plugin
To see the folder in Noatikl Desktop Standalone software (not the Audio Plugins):

Noatikl > Tools > Show folders
The folders are here:

Macs (Noatikl Desktop Standalone from Mac App Store):
(the tilde [~] in the pathname is a shortcut for your user account name)

~/Library/Containers/com.intermorphic.noatikl/Data/Library/Noatikl/intermo
rphic/templates

Macs (Noatikl Desktop Audio Plugins from IM Web store:
(the tilde [~] in the pathname is a shortcut for your user account name)

~/Library/Noatikl/

You can get to this folder by opening Finder, selecting Go -> Go to Folder... and pasting in the
above path.
Windows XP:

\Documents and Settings\All Users\Application Data\intermorphic\noatikl\te
mplates

Windows 7:

\ProgramData\intermorphic\noatikl\templates

I bought the IAP for Noatikl Free for Mac, but the app is no longer available at the Mac App Store?

Firstly, don't panic! - you will not lose out.

As of Aug 1st 2014 we removed Noatikl Free for Mac from the Mac App Store. The simple reason for this is
that we needed to cut down the number of different variants we have to maintain so as to have more time to
work on features. And, of the people who purchase Noatikl for Mac, the vast majority seemed to get the Full

https://intermorphic.com/download/guide/archive/intermorphic_com_noatikl_guide-2.7.6.pdf
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version which made it clear that was the variant to retain.

If you were one of the very few customers who did purchase the IAP in Noatikl Free for Mac then please get in
touch with us providing proof of that purchase and we will gladly give you a promo code for Noatikl for Mac.
Your installed version of Noatikl Free for Mac will of course continue to work, but that version will no longer get
any updates - these will now all come through Noatikl for Mac.

IMPORTANT: If you do decide to delete Noatikl Free for Mac then back up your Noatikl files first. See the
Copy In/Out section for Desktop Noatikl and specifically the instructions related to Noatikl 2.3 or earlier.

NB: From now on if people want to try a free version of Noatikl, then they can try the iOS version or try it via a
Desktop Plugin.

How can I download or restore an older version purchased via iTunes or Mac App Store?

You might also want to do this if iOS or macOS updates to a new version and you do not or are unwilling to do
that, you have removed Noatikl and the new version of Noatikl is no longer available for your version of iOS /
macOS (we use Apple tools to build our apps, and Apple updates to these tools change which versions of iOS
/ macOS we can build for).

iOS/OSX: In general, you should be able to download the latest version of a purchased app from the
"Purchased section" of the relevant App Store as long as we have not removed that app from sale (we will do
this for older versions after a changeover period, so as not to confuse people about which version to get).

Alternatively, you might try restoring the software from a TimeMachine backup.

See the Apple information: Download past purchases.

Note: You may also wish to refer to App Store related information: Mac App Store; iTunes App Store.

Other resources: See Apple's instructions on how to do this or (revelant to iOS only) an AppleInsider article.
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